Plymouth not working with systemd-boot and dracut on LUKS encrypted devices

Hey, yall.

I have followed all the steps on the arch wiki, but non work to activate plymouth properly. As the title suggests, I am using systemd-boot with dracut and LUKS encrypted root and swap partition.

However, after doing all the steps, I still get the the text based boot screen with boot log output. However, if I press ESC sometime during the process, it switches to a grey screen with three white-ish dots in the middle, blinking one at the time. Pressing ESC when prompted for the LUKS passphrase, the background also turns gray, but with the text that prompts me for the password.

I have added splash and quiet to kernel parameters:

$ sudo cat /etc/dracut.conf.d/cmdline.conf                                                                       
kernel_cmdline+=" splash quiet "

I make sure intel driver is loaded early:

$ sudo cat /etc/dracut.conf.d/video.conf  
force_drivers+=" i915 "

I have made sure that dracut builds initrd with plymouth:

$ sudo dracut --hostonly --no-hostonly-cmdline --force /efi/5c6af3eadd8d4d76909952eb1df24ba6/6.4.4-arch1-1/initrd
dracut: *** Including module: plymouth ***

Previewing themes as explained in the arch wiki also does not work showing a black screen with a blinking cursor. Furthermore, pressing ESC will show the gray screen with blinking dots described above.

I haven’t seen anything in the logs that suggests that something is wrong, although perhaps im not searching for the right things.

Is there something Im missing?

Thanks for any help :slight_smile:

did you set up the kernel paramater


according to the article this should allow you to log here


what logs have you looked at? I personally don’t like plymouth so not sure what the boot log would say.

Is this part working? Generally we expect kernel params to be in /etc/kernel/cmdline

After changing it, you would need to run sudo reinstall-kernels

1 Like

Added this, but there is no file /var/log/plymouth-debug.log.

Although journal says:

dracut-cmdline[234]: Using kernel command line parameters:  splash quiet plymouth.debug rd.driver.pre=i915

I mean, these do refer to the kernel parameters, no?

Don’t know if this is working. I just followed the this guide to add kernel parameters with dracut’s initramfs. I will try your suggestion :slight_smile:

It should work, and you can see when you are in systemd-boot or in grub that by pressing e you get to edit the kernel cmdline and you should see the parameters then

Setting them in /etc/kernel/cmdline worked. I dont know why setting them via dracut did not work as per what was described in the link.


It is probably one of two things. Either that doesn’t make the kernel options available early enough in the boot process or because the image is built with --no-hostonly-cmdline


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.