Plexamp 3.0

Is anybody else using Plexamp’s newest version?

Works fine on mobile and on Windows. Launches on Arch after 3.0.3 release, but can’t get past the sign in window.

Looked around Plex forums, but no dice. Lots of people are having the same problem it seems.

How did you get the program (which is an AppImage both ways)?
Build it via AUR or did you download from the website?
Did you already read this link ?
Start it from your terminal and post the output. Unlike other AppImages it doesn’t include all it needs. At least the version from the homepage.

You’ll need a Plex Media Server and an active Plex Pass to use this app

Is the Plex Media Server installed and configured correctly?

Yeah Plex server is working great. I tried running the appimage in konsole and this is what I got:

"Gtk-Message: 08:41:36.174: Failed to load module “appmenu-gtk-module”
xdg-mime: application argument missing
Try ‘xdg-mime --help’ for more information.
Started Media Service: false
Linux: Registering MPRIS service.
Linux: Error registering media services: Cannot find module ‘abstract-socket’
Require stack:

  • /tmp/.mount_PlexamKIMx0B/resources/app.asar/node_modules/dbus-next/lib/connection.js
  • /tmp/.mount_PlexamKIMx0B/resources/app.asar/node_modules/dbus-next/index.js
  • /tmp/.mount_PlexamKIMx0B/resources/app.asar/main.js

[9931:0517/084137.037472:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERA
TION : glBufferData: <- error from previous GL command
(node:9940) Electron: Loading non context-aware native modules in the renderer process is deprecated
and will stop working at some point in the future, please see https://github.com/electron/electron/is
sues/18397 for more information
(node:9940) Electron: Loading non context-aware native modules in the renderer process is deprecated
and will stop working at some point in the future, please see https://github.com/electron/electron/is
sues/18397 for more information
Checking for update
Update for version 3.0.3 is not available (latest version: 3.0.3, downgrade is disallowed).
checkForUpdatesAndNotify called, downloadPromise is null"

Let’s try to figure it out step by step.

Install the package appmenu-gtk-module
Then try to start again. Post the output.

I installed appmenu-gtk-module from pamac. Still get the same message, just without the appmenu-gtk-module error.

Removed the appimage, reinstalled from AUR. Tried running with konsole. Got an error that “gtk-update-icon” was missing. Trying to install that now. It’s taking a long time to install…

Plex forums suggest that “–disable-seccomp-filter-sandbox” command may help. Trying to figure out where to add it.

That’s exactly what I expected to happen. That’s why I wrote step by step.

So we’ll wait and see.