Playing with discord screensharing drops my performance


When I’m trying to screenshare in discord while playing a really heavy game like Doom Eternal, my performance goes really low.
It’s a bit weird, because Doom Eternal performs better than W10, but when I screeshare the game goes really bad. Specifically, my CPU usage skyrockets only when screensharing.

I’m using EndeavourOS with KDE plasma, kernel linux x86_64 5.14.12-arch1-1, an Intel i7-6700K 4.3 GHz, NVIDIA GTX 1070 with 470.74 drivers. The game is running with proton 6.7 inside SteamPlay.
I’m using Discord Canary 101473, but I’ve tried the stable version too and does the same issue. Discord has hardware acceleration ON and doesn’t fix if I turn off.

I’m pretty new on this community, so I don’t know what kind of log I could provide on this message. However, I took some screenshots using OBS and then, spectacle:

That’s before screensharing (normal):

That’s after screensharing (poor perfromance):

Any idea on what’s going on?

Welcome to the forum!

I don’t think Discord on Linux has support for hardware acceleration which would likely contribute to bad performance when sharing your screen.

Others with similar experiences here.

1 Like

It’s strange, because the “enable hardware acceleration” option is still in the linux version and doesn’t turn off. But at least is just discord isn’t well optimised for linux.

I’ve seen an unofficial discord client Ripcord, but in the arch wiki says I’ll probably get banned if I used it.

I’ll try to run discord on firefox or chromium, maybe it’s hardware accelerated on those browsers.


Hardware accelerated encoding isnt supported for FF, Chomium, or Discord which uses embedded chromium.

Decode is mostly fine on FF these days with recent updates but Chromium still doesnt. Youre encoding/decoding with CPU.

The thing is running discord on firefox still doesn’t enable hardware acceleration and keeps using cpu. Unfortunately, I think there’s no solution until Discord fixes by itself.

However, I’ve seen the discord-arch-electron package, but for some reason I can’t make discord use system electron.

I think its discord using old electron which is a hit or miss, my google chrome on linux is full hardware accelerated with the latest updates.