Playing 4k videos with mpv and nvidia graphics

I am dual booting with windows 11. my specs are i3wm, rtx 3060, i7 12th. I installed endeavour os with nvidia drivers and systemd boot and changed settings to ibt=off in boot options. I also installed optimus-switch and chnaged to nvidia graphic card but when i run a 4k video it still drops frames and stutters a lot.
any way to solve this please?

Could you show the output of the following commands:

inxi -Fza
pacman -Qs xf86-video
lspci -vnn | grep -PA10 '3D|Display|VGA'

And here’s some reading unless you already read it:

I’m not very familiar with using mpv but i have seen some other reports using this? Not sure if where to put this or add? Maybe just when running mpv?

mpv --no-config --hwdec=vaapi

Shouldn’t it be --hwdec=nvdec ?

Maybe I don’t know? I just read some other site about what worked and didn’t as I am not familiar with mpv. Looks like they were using vappi and say’s it worked? But you probably know better if you are using mpv with nvidia. :wink:

:hole: :man_walking:

Edit: It’s here i guess.

I’m not using that thing anymore… ehhe
But when I was using a GTX 1650 in my XFCE days, I was getting hardware acceleration in MPV using this option, hwdec=nvdec.
As far as I remember, hwdec=auto also used to work

More details:

What you don’t use Nvidia anymore? :scream_cat:
What you got AMD?

Not anymore :slight_smile:
Since I started to use Linux daily, nvidia and me don’t go along anymore, one of us had to quit and it was Nvidia heheh

I got a 6600xt, but my nephew wanted a computer and my sister couldn’t afford one, so I got him a computer and gave him my 6600xt.
Bought a 6750xt for me

1 Like

That’s what i have sitting here brand new in a box RX6750XT. :heart_eyes:

Edit: Waiting for the rest of the parts.

pwr supply
nvme drives

Just got the case.


1 Like

It is a great GPU :slight_smile:

1 Like

I’m paring it up with the Ryzen 5800X

Edit: mpv should work good with it! :wink:

1 Like

AM4 will be here for a long time, it is a great platform, huge support, parts all over the place for replacement and upgrades…
I’m not sure if we will ever see a socket like that again, I mean, mobo manufactures are not making so much money with newer boards every 2 years as they used to…

I don’t think it can run MPV without stuttering :rofl: :rofl:
MPV is too heavy :sweat_smile:

1 Like

inxi -Fza

  Kernel: 6.1.12-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: initrd=\3a4785096b474312a1739f175324bcb0\6.1.12-arch1-1\initrd
    nvidia-drm.modeset=1 nvme_load=YES ibt=off rw rootflags=subvol=/@
  Desktop: i3 v: 4.22 info: i3bar vt: 7 dm: LightDM v: 1.32.0
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: Micro-Star product: Crosshair 15 B12UEZ v: REV:1.0
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Micro-Star model: MS-1583 v: REV:1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: E1583IMS.108 date: 04/07/2022
  ID-1: BAT1 charge: 48.1 Wh (100.0%) condition: 48.1/52.0 Wh (92.4%)
    volts: 13.0 min: 11.4 model: MSI BIF0_9 type: Li-ion serial: N/A
    status: full
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x429
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 1081 high: 2701 min/max: 400/2701 boost: disabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 1345 2: 2133
    3: 881 4: 705 5: 652 6: 645 7: 652 8: 400 9: 761 10: 1386 11: 635 12: 2701
    13: 540 14: 735 15: 561 16: 544 17: 2701 18: 2701 19: 465 20: 491
    bogomips: 107560
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Micro-Star MSI
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:46a6
    class-ID: 0300
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q]
    vendor: Micro-Star MSI driver: nvidia v: 525.89.02
    alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2023-02) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 ports: active: none empty: HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 10de:2520 class-ID: 0300
  Device-3: Bison HD Webcam type: USB driver: uvcvideo bus-ID: 1-6:3
    chip-ID: 5986:211b class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.7 driver: X: loaded: modesetting,nvidia
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
    s-diag: 777mm (30.58")
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x152a built: 2020 res: 2560x1440
    hz: 165 dpi: 189 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 2560x1440
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio
    vendor: Micro-Star MSI driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  Device-2: NVIDIA GA106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
  Sound API: ALSA v: k6.1.12-arch1-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.66 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  IF-ID-1: tailscale0 state: unknown speed: -1 duplex: full mac: N/A
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-10:4 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 9.66 GiB (1.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVL21T0HCLR-00B00 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: GXA7401Q temp: 39.9 C scheme: GPT
  ID-1: / raw-size: 441 GiB size: 441 GiB (100.00%) used: 9.13 GiB (2.1%)
    fs: btrfs dev: /dev/nvme0n1p9 maj-min: 259:9
  ID-2: /home raw-size: 441 GiB size: 441 GiB (100.00%)
    used: 9.13 GiB (2.1%) fs: btrfs dev: /dev/nvme0n1p9 maj-min: 259:9
  ID-3: /var/log raw-size: 441 GiB size: 441 GiB (100.00%)
    used: 9.13 GiB (2.1%) fs: btrfs dev: /dev/nvme0n1p9 maj-min: 259:9
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p8 maj-min: 259:8
  System Temperatures: cpu: 42.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 387 Uptime: 3m wakeups: 3 Memory: 15.33 GiB
  used: 2.07 GiB (13.5%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: 975 pm: pacman pkgs: 969
  libs: 272 tools: yay pm: flatpak pkgs: 6 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.25```

pacman -Qs xf86-video

local/xf86-video-intel 1:2.99.917+923+gb74b67f0-1 (xorg-drivers) Intel i810/i830/i915/945G/G965+ video drivers

lspci -vnn | grep -PA10 ‘3D|Display|VGA’

00:02.0 VGA compatible controller [0300]: Intel Corporation Alder Lake-P Integrated Graphics Controller [8086:46a6] (rev 0c) (prog-if 00 [VGA controller])
	DeviceName: Onboard - Video
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:1333]
	Flags: bus master, fast devsel, latency 0, IRQ 170
	Memory at 6202000000 (64-bit, non-prefetchable) [size=16M]
	Memory at 4000000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 5000 [size=64]
	Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GA106M [GeForce RTX 3060 Mobile / Max-Q] [10de:2520] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:1333]
	Flags: bus master, fast devsel, latency 0, IRQ 171
	Memory at 81000000 (32-bit, non-prefetchable) [size=16M]
	Memory at 6000000000 (64-bit, prefetchable) [size=8G]
	Memory at 6200000000 (64-bit, prefetchable) [size=32M]
	I/O ports at 4000 [size=128]
	Expansion ROM at 82000000 [virtual] [disabled] [size=512K]
	Capabilities: <access denied>
	Kernel driver in use: nvidia
	Kernel modules: nouveau, nvidia_drm, nvidia

It’s rendering on Intel!

API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes

Edit: You would need to switch graphics in order to use Nvidia.

I agree the B450 platform was really good and it’s only gotten better now with B550 and X570 on AM4 socket.

how to change it to nvidia?

Indeed!! There are people today running Zen 3 in a X370 board…

1 Like

Not sure what laptop you have? Looks like MSI product. Does it have the ability to switch graphics to dedicated or hybrid or integrated in the UEFI Bios settings?

no it does not have bios option. anyways mpv is working good with hwdec. is there any guide to install vulkan drivers? can some one list packages for vulkan drivers?