Plasma6 Update - somehow no temperature of hard disks anymore

So, I just pulled the trigger and did the dreaded update. I succesfully avoided the wayland step, so now I am n Plasma6 with X11, and almost everything is working fine. Some of my widgets ain’t there yet, but developers are on it, so that is that - with one exception. While I was checking the widget situation for this exception something confused me:
In the past I used the widget “Thermal Monitor” - devolpment seems inexistent. Bummer. But I wait a bit, I copuld live without it, as there is an almost as good replacement available in the “store” already: - works the same, looks a bit less good, but that’s that. Here is my issue now. While I was adding my sensors to the widget I missed two of those: Where are my HDD / SDD temp sensors? What is going on here? Well, should not be a big issue, shouldn’t it? I can solve that, can I? Well, spoiler, hence the topic, I can’t!
I started of with sensors:

Adapter: ISA adapter
in0:                     1.03 V  (min =  +0.00 V, max =  +1.74 V)
in1:                     1.01 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in2:                     3.34 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in3:                     3.34 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in4:                     1.02 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in5:                   144.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in6:                   784.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in7:                     3.34 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in8:                     3.31 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in9:                     1.80 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in10:                    0.00 V  (min =  +0.00 V, max =  +0.00 V)
in11:                  656.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in12:                    1.10 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in13:                  680.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in14:                    1.48 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
fan1:                     0 RPM  (min =    0 RPM)
fan2:                   379 RPM  (min =    0 RPM)
fan3:                   338 RPM  (min =    0 RPM)
fan4:                     0 RPM  (min =    0 RPM)
fan5:                     0 RPM  (min =    0 RPM)
fan6:                     0 RPM  (min =    0 RPM)
fan7:                     0 RPM  (min =    0 RPM)
SYSTIN:                 +37.0°C  (high = +80.0°C, hyst = +75.0°C)  sensor = CPU diode
CPUTIN:                 +37.0°C  (high = +115.0°C, hyst = +90.0°C)  sensor = thermistor
AUXTIN0:                +38.0°C  (high = +115.0°C, hyst = +90.0°C)  sensor = thermistor
AUXTIN1:               -128.0°C    sensor = thermistor
AUXTIN2:                +46.0°C    sensor = thermistor
AUXTIN3:                 +1.0°C    sensor = thermistor
SMBUSMASTER 0:          +42.5°C  
PCH_CHIP_TEMP:           +0.0°C  
PCH_CPU_TEMP:            +0.0°C  
PCH_MCH_TEMP:            +0.0°C  
Agent0 Dimm0:            +0.0°C  
TSI0_TEMP:              +42.6°C  
intrusion0:            ALARM
intrusion1:            ALARM
beep_enable:           disabled

Adapter: PCI adapter
Composite:    +37.9°C  (low  = -20.1°C, high = +89.8°C)
                       (crit = +94.8°C)

Adapter: PCI adapter
SVI2_Core:     1.40 V  
SVI2_SoC:      1.08 V  
Tdie:         +42.6°C  (high = +95.0°C)
Tctl:         +42.6°C  
Tccd1:        +48.8°C  
Tccd2:        +38.5°C  
SVI2_P_Core:  43.89 W  
SVI2_P_SoC:   17.20 W  
SVI2_C_Core:  28.33 A  
SVI2_C_SoC:   15.89 A  

Adapter: PCI adapter
vddgfx:        6.00 mV 
fan1:           0 RPM  (min =    0 RPM, max = 3300 RPM)
edge:         +62.0°C  (crit = +100.0°C, hyst = -273.1°C)
                       (emerg = +105.0°C)
junction:     +67.0°C  (crit = +110.0°C, hyst = -273.1°C)
                       (emerg = +115.0°C)
mem:          +66.0°C  (crit = +100.0°C, hyst = -273.1°C)
                       (emerg = +105.0°C)
PPT:          36.00 W  (cap = 255.00 W)

Adapter: Virtual device
temp1:        +38.0°C  

Adapter: PCI adapter
Composite:    +26.9°C  (low  = -20.1°C, high = +89.8°C)
                       (crit = +94.8°C)

Nope, not what I expected. That is so because of:

inxi -D
  Local Storage: total: 18.66 TiB used: 8.7 TiB (46.6%)
  ID-1: /dev/nvme0n1 vendor: Seagate model: FireCuda 530 ZP2000GM30013
    size: 1.82 TiB
  ID-2: /dev/nvme1n1 vendor: Seagate model: FireCuda 530 ZP2000GM30013
    size: 1.82 TiB
  ID-3: /dev/sda vendor: Samsung model: SSD 860 PRO 512GB size: 476.94 GiB
  ID-4: /dev/sdb vendor: Seagate model: ST16000NM001G-2KK103 size: 14.55 TiB

Where are the sensors of my two non-nvme HardDisks? I absolutely know that they have those available.
I just reran sudo sensors-detect, with absolutely no change.
After a bit of web research I installed hddtemp, just to be sure… lo and behold:

sudo hddtemp /dev/sda
WARNING: Drive /dev/sda doesn't seem to have a temperature sensor.
WARNING: This doesn't mean it hasn't got one.
WARNING: If you are sure it has one, please contact me (
WARNING: See --help, --debug and --drivebase options.
/dev/sda: Samsung SSD 860 PRO 512G B              �@:  no sensor

sudo hddtemp /dev/sdb
/dev/sdb: ST16000NM001G-2KK103: drive is sleeping

The device is not sleeping, both devices have hardware sensors - what did the Upgrade to plasma6 to my poor little drives? Currently I am out of ideas - I really like to have all my temps available…

If sensors isn’t reporting the information, what does that have to do with plasma 6? I think something else must have updated at the same time as plasma 6.

Edit: I checked sensors on my system and I also don’t see any of my hard drives. Only the nvme.

I don’t know. All I know is that before the Update the drive sensors where there, after it they disappeared. From the user perspective it does not matter so much, for the RCA it does much more.
So how can I check what was updated with this update?

Yeah, but it also matters for the developers of said projects as well. Getting bug reports for things that are outside of your control is a waste of time. Anyways, I usually use this command paclog | grep upgraded | tail -n 200. That will list the last 200 thing that were updated. Check the dates to see what all was updated.

I’ll also check on my system to see when the last time lm_sensors was updated and see if there is anything relevant.

1 Like

Found this section in the arch wiki

Tried it myself and now I see the drive temps when running sensors.


That did the trick (after learning how to permanently load it and a second rebbot)! TYVM!

1 Like

Glad to be of service. I do wonder why this was not necessary before though?

Yes… i tried it also and it seems to work for me.

[ricklinux@rick-ms7c37 ~]$ sensors
Adapter: SCSI adapter
temp1:        +30.0°C  (low  = +14.0°C, high = +55.0°C)
                       (crit low = +10.0°C, crit = +60.0°C)
                       (lowest = +23.0°C, highest = +30.0°C)

Adapter: PCI adapter
vddgfx:      750.00 mV 
fan1:        2038 RPM  (min =    0 RPM, max = 3700 RPM)
edge:         +49.0°C  (crit = +91.0°C, hyst = -273.1°C)
PPT:          18.12 W  (cap = 120.00 W)

Adapter: PCI adapter
Tctl:         +48.2°C  
Tccd1:        +49.0°C  

Adapter: PCI adapter
Composite:    +38.9°C  (low  =  -5.2°C, high = +79.8°C)
                       (crit = +84.8°C)

Adapter: SCSI adapter
temp1:        +26.0°C  

Adapter: PCI adapter
PHY Temperature:  +56.5°C  
MAC Temperature:  +55.5°C  

Adapter: PCI adapter
Composite:    +49.9°C  (low  =  -5.2°C, high = +79.8°C)
                       (crit = +84.8°C)

[ricklinux@rick-ms7c37 ~]$
1 Like

That explains why I couldn’t see drive temperatures in glances even though I had hddtemp installed…

Fixed now, thank you :hugs:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.