Plasma system monitor sensor gpu

Hi!

The widget system monitor sensor now can’t display gpu data (temp, workload etc…). It shows allways at 0. This is a global plasma problem I think.
First happended at a totally different machine. Laptop with Intel/nvidia prime 2060rtx mobile system and Manjaro running a few weeks ago.
Now happened at EOS on desktop PC with deactivated interated GPU and only running nvidia 1070ti.
So can’t display GPU workload in widget and can’t display GPU workload in systemmonitor of plasma. Worked until a few days ago fine.

So, is there a solution?

Greetings to all

Which system monitor Widget are you referring to?

Edit: System Monitor is working and i can add a desktop Widget for CPU but the System Monitor Sensor Widget doesn’t allow me to even set the settings.

I had this problem long ago and just removed the GPU sensors. You should make a bug report. Or I should…
EDIT: bugs.kde.org is down :joy:

1 Like

Now that’s a real bug! :wink:

Edit: The page comes up for me? :man_shrugging:

1 Like

I mean plasma-systemmonitor and the plasmoid system monitor sensor (preinstalled in plasma). Both can’t show GPU workload and temps (from my nvidia chips) anymore.

System Monitor only shows cpu but is working. I tried system monitor sensor widget but doesn’t allow to add any settings.

Edit: I played around with system monitor sensor and it does load the presets and is working but there is no GPU setting. :man_shrugging:

There you can see the 0% workload of my GPU and the 0’ temp.
It worked since a few updates ago. Same in the widget.

You can add sensors whatever you want. The point is, it don’t work anymore.
In the plasmoid “system monitor sensor” the same issue.

Mine is showing temperature but no gpu usage.

Edit: It does show memory used

How do you add GPU to the System Monitor?

Edit: It actually is working. I saw GPU usage jump up a few times as much as 44% but I’m only browsing and texting. So i think it is working.

I also think that there is a bug somewhere. CPU load works for me, but GPU data is not shown anymore in the system monitor. The Nvidia control panel shows the temperature correctly, system monitor not at all. GPU load is usually about 10% in idle. This is new. A few days ago everything has worked.

GPU data not shown:

CPU works fine:

I haven’t figured out how to add the GPU to the system monitor yet. But, if i add it as a widget the GPU is usually always 0 but i do see it move occasionally when i was trying it. It went as high as 44% but normally it just sits at 0. :man_shrugging: Hopefully someone puts a bug report in on it.

You only need to go to the hamburger menu and click “get new pages”. Then search for GPU and you can’t miss it :slight_smile:


2 Likes

Okay… this is good. I was trying to figure out how to add gpu to the top window in overview. But this is better i think.

GPU stats still at zero value

nvtop is working

but I need the values in plasma system monitor widget, and thats broken :frowning:

Wait until you leave it open for a while, and it runs away with all your memory…
Plasma’s monitor is a little buggy.

Ah so it’s a memory hog?

I have the same problem. It appears to be due to the driver update, I believe 525 Geforce. I am actually looking for a solution as I would like to keep a track of the GPU usage and temperature while rendering lighting.

No GPU usage, temperature, VRAM is not working. Just shows 0.