Plasma Operation Issues

I just installed EndeavourOS on a new laptop, with the Plasma environment.
The installation was carried out without any problem.
But when I log in, I have big problems with Plasma: the screen freezes regularly, the mouse freezes, I can’t access the SystemSettings, I can’t change the screen resolution,…
I tried the installation with Manjaro, and everything works perfectly without doing any manipulation.
I have an intel i7 processor with Evo.

Thank you for your help in helping me resolve the issue (Packages to install,…) and allow me to get EndeavorOS working properly with Plasma.


Did you try disabling Wayland instead of Xorg yet? I’ve had similar issues before. And that helped.

It would be helpful i supplied some hardware information? You can post the url.

inxi -Faz | eos-send log
1 Like


Thank you for your help.
How to do to disabling Wayland instead of Xorg yet ?
Thank you.


Hello ricklinux.
This is the result :

inxi -Faz
Kernel: 6.1.12-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
root=UUID=9c7006a1-bb25-404f-a043-5cb5e0a296d1 rw quiet
root=/dev/mapper/luks-1716977c-b5a9-4791-940e-ae7566da51cc splash
Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
Distro: EndeavourOS Linux base: Arch Linux
Type: Laptop System: LG product: 17Z90Q-G.AD78F v: 0.1
serial: <superuser required> Chassis: type: 10 v: 0.1
serial: <superuser required>
Mobo: LG model: 17Z90Q v: FAB1 serial: <superuser required> UEFI: Phoenix
v: A1ZG0400 X64 date: 08/23/2022
ID-1: CMB0 charge: 65.9 Wh (82.4%) condition: 80.0/80.0 Wh (100.0%)
volts: 8.3 min: 7.7 model: LG LGES-LG type: Li-ion serial: <filter>
status: discharging cycles: 14
Info: model: 12th Gen Intel Core i7-1260P bits: 64 type: MST AMCP
arch: Alder Lake level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
microcode: 0x424
Topology: cpus: 1x cores: 12 mt: 4 tpc: 2 st: 8 threads: 16 smt: enabled
cache: L1: 1.1 MiB desc: d-8x32 KiB, 4x48 KiB; i-4x32 KiB, 8x64 KiB
L2: 9 MiB desc: 4x1.2 MiB, 2x2 MiB L3: 18 MiB desc: 1x18 MiB
Speed (MHz): avg: 1644 high: 2500 min/max: 400/4700:3400 scaling:
driver: intel_pstate governor: powersave cores: 1: 512 2: 2500 3: 481 4: 832
5: 1042 6: 2500 7: 2500 8: 2500 9: 867 10: 2500 11: 997 12: 1075 13: 2500
14: 2500 15: 2500 16: 505 bogomips: 79888
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel Alder Lake-P Integrated Graphics vendor: LG driver: i915
v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:46a6
class-ID: 0300
Device-2: Chicony LGE FHD Camera type: USB driver: uvcvideo bus-ID: 3-2:2
chip-ID: 04f2:b772 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.7 compositor: kwin_x11 driver: X:
loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 2560x1600 s-dpi: 144 s-size: 451x282mm (17.76x11.10")
s-diag: 532mm (20.94")
Monitor-1: eDP-1 model: LG Display 0x06ea built: 2021 res: 2560x1600
hz: 60 dpi: 178 gamma: 1.2 size: 366x229mm (14.41x9.02") diag: 432mm (17")
ratio: 16:10 modes: 2560x1600
API: OpenGL v: 4.6 Mesa 22.3.5 renderer: Mesa Intel Graphics (ADL GT2)
direct-render: Yes
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: LG
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:51c8 class-ID: 0401
Sound API: ALSA v: k6.1.12-1 running: yes
Sound Server-1: JACK v: 1.9.22 running: no
Sound Server-2: PulseAudio v: 16.1 running: yes
Sound Server-3: PipeWire v: 0.3.65 running: yes
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:3
chip-ID: 8087:0033 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Local Storage: total: 953.87 GiB used: 49.62 GiB (5.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVL21T0HCLR-00B00 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: GXA7601Q temp: 32.9 C scheme: GPT
ID-1: / raw-size: 953.57 GiB size: 937.53 GiB (98.32%)
used: 49.62 GiB (5.3%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
mapped: luks-1716977c-b5a9-4791-940e-ae7566da51cc
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 472 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Alert: No swap data was found.
System Temperatures: cpu: 50.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 324 Uptime: 11m wakeups: 750 Memory: 31.07 GiB
used: 3.31 GiB (10.7%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
pkgs: 1847 libs: 422 tools: pamac,yay pm: flatpak pkgs: 0 Shell: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.25

Thank you

Update your system first and reboot.

sudo pacman -Syyu

1 Like

Hello @Patrick_F

You aren’t fully updated is the first thing as @petsam has said so that’s what needs to be done first. The only thing i see is you are using lvm and also luks. I’m not well versed with lvm partition layout but this is the only thing i can see where there might be an issue. I’m not sure why you are wanting to use lvm or if it is set up correctly? I will have to leave this for someone who has the expertise with lvm to go through how you have it set up which would require some info.

ID-1: / raw-size: 953.57 GiB size: 937.53 GiB (98.32%)
used: 49.62 GiB (5.3%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
mapped: luks-1716977c-b5a9-4791-940e-ae7566da51cc

Edit: Would need to see the partition layout under for lvm beyond just what this shows.

You have to edit the corresponding config file of the displaymanager you are using.

For GDM it would be done with this command:

sudo nano /etc/gdm3/custom.conf

In the file, look for the line that says #WaylandEnable=false. You can uncomment this line to disable Wayland, re-start the service, or reboot.

Doesn’t look like the OP is using Wayland? :wink:

Shoot. Me.

1 Like

don’t think it’s GDM

have a glance please

Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM

Just don’t worry about what I wrote, since you are NOT using Wayland, as @ricklinux remarked above, telling from your inxi that you have Xorg running, instead (x-server).

Give the LTS kernel a shot.

I have the same issue. Bought a new System76 Darter Pro for work. (tech specs) I tested it out with Ubuntu and PopOS! which both work perfectly.

I have endeavorOS installed on two other personal machines and haven’t had issues. Using the latest ISO (EndeavourOS_Cassini_neo_22_12.iso) with KDE Plasma as the DE, it is unusable. I verified it is using XOrg graphics too.

The symptom is the menus are broken and don’t take keyboard input and get locked up. The graphics in the launcher or the Settings flicker and I can perhaps type a couple letters but then it’s totally broken. Moving the mouse over the menu causes it to flicker between modes of “favorites” and filtered.

I also tested with Xfce and it works perfectly.

I also tried removing all the .kde config and cache but it doesn’t fix it.

This was using the LTS Kernel.


So, the problem come from Kde Plasma.
The question is : How to solve the problem !

It’s Intel Iris Xe? Have you tried uninstalling xf86-video-intel.

1 Like

Hi @ricklinux,

Yes, uninstalling xf86-video-intel completely fixed the issue for me! Thanks!

Okay, I’m glad that worked. I was just guessing it might but wasn’t sure.

1 Like

Thank you for the info.
I will install EndeavourOS later.
I hope this will work.
Quick question: what to replace xf86-video-intel ?

Thank you very much