Plasma: Disable Peek at Desktop animation

Linux user for a decade and a half but installing EndeavourOS yesterday is my first real encounter with KDE.

Having an Nvidia card means I’m sticking to X11 for now due to stability issues. My experience of KDE on X11 is that animations are nowhere near as smooth as on Wayland. Which means I want to disable them as much as possible. Which I have done in Settings | Window Management | Desktop Effects.

One minor thing: I can’t seem to get rid of the Peek at Desktop effect where the task bar shrinks a bit into a rounded rectangle. This also plays when moving to a virtual desktop with no windows on it.

It’s a tiny thing but on X11 it plays out in a really ugly three-step animation that mars the overall good impression that Plasma has made. Any ideas?

You could try change the animation speed to instant and see if this helps. The option should be on the first screen you see in system settings

Thanks. That definitely gets rid of the stuttering animation. Ideally I would be able to have the taskbar stay in place but it’s better than nothing.

Do you have it set to floating? If it is you could see if turning this off helps

1 Like

That did it, thank you :slight_smile:

Spelling it out, just for the record:

  1. Right click the task bar
  2. Enter edit mode
  3. Toggle Floating off in the small settings window
  4. Right click the task bar again
  5. Exit Edit mode

EDIT: I am impressed with how configurable KDE is… but man alive, it feels like a lifetime study figuring out where to find the right setting :smile:

2 Likes

For sure at times, I’ve been playing around with it for a while now and still keep learning new things I can do or different ways of doing them.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.