Plasma Desktop Widgets Crashing After Reboot

Greetings All,

I did a fresh install and noticed that my system boots to a black screen with cursor, or sometimes just a black screen after adding desktop widgets (system monitor, wunderground).
The only way I got back to my desktop was to boot and quickly got to TTY and remove the widgets from my desktop using the prompt. Task bar widgets seem to work, but not much on desktop.
Any help with this would be most appreciated.


Kernel: 6.6.33-1-lts arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A wm: kwin_wayland dm: SDDM
Distro: EndeavourOS base: Arch Linux
Type: Desktop Mobo: Gigabyte model: H55M-S2V serial:
BIOS: Award v: F3 date: 09/10/2010
Info: dual core model: Intel Core i3 550 bits: 64 type: MT MCP
arch: Westmere rev: 5 cache: L1: 128 KiB L2: 512 KiB L3: 4 MiB
Speed (MHz): avg: 1307 high: 1456 min/max: 1197/3192 cores: 1: 1200
2: 1375 3: 1456 4: 1200 bogomips: 25610
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: NVIDIA GT218 [GeForce 210] vendor: ASUSTeK EN210 SILENT
driver: nouveau v: kernel arch: Tesla pcie: speed: 2.5 GT/s lanes: 16 ports:
active: HDMI-A-1 empty: DVI-I-1,VGA-1 bus-ID: 01:00.0 chip-ID: 10de:0a65
temp: 49.0 C
Display: wayland server: v: with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,nouveau,nv,vesa dri: nouveau gpu: nouveau display-ID: 0
Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A
API: EGL v: 1.5 platforms: device: 0 egl: 1.4 drv: nouveau device: 1
drv: swrast gbm: egl: 1.4 drv: nouveau surfaceless: egl: 1.4 drv: nouveau
wayland: egl: 1.4 drv: nouveau x11: egl: 1.4 drv: nouveau
API: OpenGL v: 4.5 compat-v: 3.3 vendor: mesa v: 24.1.1-arch1.1 glx-v: 1.4
direct-render: yes renderer: NVA8 device-ID: 10de:0a65 display-ID: :1.0
API: Vulkan Message: No Vulkan data available.

Welcome @autotech :wave: :sunglasses: :enos_flag:

I’ve not messed around with widgets recently, but you might confirm the widgets are specifically built for Plasma 6, before installing them. There are a couple of different versions of Wunderground for example, for Plasma 5, and Plasma 6.


I figured that much, so I tried to stay within the kde provided widgets (System monitor - Application table). Still no dice. When no widgets are present on the desktop, all seems well.
It would have been a problem if I updated with desktop widgets and then this would happen. I would have not known what the issue would be. Hopefully I can future proof by fixing this issue.


Which provided widget are you using? It doesn’t show under the name you provided and there are a few when I search for it that show up

The only extra widget I have on my system is the clock I use on the desktop with no issues so seeing if I can reproduce, if it is a third party widget please provide a link to it or show where I can get it so I know I am trying the right thing out

System Monitor Sensor.
Change from pie chart to application table in options.

Memory Monitor seems to work just fine (pie chart).
I haven’t checked the rest.
Perhaps my system specs are part of it too.
Old nvidia card running nouveau.

Ok I’ll test it out soon as, just testing something else now and have to pop out for about an hour but I’ll set this and see what happens when I turn on the PC when I get home

Maybe but always good to see if someone can reproduce. Not sure if you mentioned but did have you tried under a new user to confirm it isn’t any old configurations?

Certainly could not be an old config. This is fresh from a clean install.

Ok cool, will let you know when I’m back home if I get the same issue or not

I couldn’t reproduce the bug on my machine

I think it might only be affecting very old nvidia cards. Perhaps cards that are supported by the official driver on older kernels only (ex. 340xx driver on Kernel 5.10 and below).

Guessing you have tried on the mainstream kernel?

Did you try x11 instead of wayland?

And welcome to the purple side! :smile:

1 Like

This just shows me where my mind is at today, it’s normally one of the first questions I ask

And ditto to this, sorry for not welcoming you earlier

1 Like

I appreciate the welcome.
I have tried Wayland with the latest lts kernel.
I’m trying to stick with non-proprietary GPU drivers. The official driver is no longer supported on newer kernels, which causes problems on major updates.

I will attempt X11 and report back.



1 Like

After a ton of research and plenty of driver/kernel installs, it looks like my card has simply hit its stride. A newer card is in order. Other arch distro users are also having trouble with it. The old solution was to install kernel 5.10 or older and manually install the driver. You would repeat this process every other update, regardless of ignore flag. I appreciate the good Gentlemen that helped out. Many thanks.


Dang, at least you know what’s going on I suppose