Pipewire-Pulse showing "HDMI (unplugged)" as only output device

Good day to everyone. Suddenly I’ve been experiencing issues with Pipewire, that is, the sound just stopped working. If I go to the Volume Control Panel, the only available port is “HDMI/Display port (unplugged)” and I cannot change it to anything else. The microphone is not detected at all. The pipewire service is enabled and running.

I’m a newbie so I’m not sure what I should include, so please do tell me which further information I should provide.

Thank you very much in advance

It seems to have something to do with the last update, in which Pipewire changed from 1.03 to 1.04. I tried downgrading it with the cache, but I can’t since there are several things dependent on it.

Update: it seems to have fixed itself somehow.

Have you got pavucontrol installed? Have a look at the configuration tab, see if you can change there.

Yes, it’s precisely there where there aren’t any other options

Hello All!

I can confirm the same problem when I upgraded wireplumber and libwireplumber
from version (0.4.17-1 => 0.5.0-2).

Running fully updated Endeavouros on Thinkpad X270. (https://0x0.st/XzaA.txt)

It took me a while to track down which package was causing the disappearance of the sound device. Big thanks to timeshift gtk, I was able to restore last working configuration and gradualy upgrade until a trace down which package was causing trouble.

Currently, I updated pacman.conf with:
IgnorePkg = wireplumber libwireplumber
and everything seems ok.

edit 1 (31/3/2024): to add specs of my laptop


Yes, seems to be the issue. I found in configuration there appears to be an option for “Analog Stereo Duplex” which made it work with the new version, but it does seem to have issues.

I had same issue, thanks for the solution.

I couldn’t find any issue open on the wireplumber git page. Are we supposed to open one for this as we’ve encountered it?

First post btw, not sure if replies like this to a solved issue are ok, sorry if not.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.