Pipewire-pulse having issues

Hello, I cloned a rice which uses Pipewire-pulse as the audio manager. It was working fine but it has started to break recently. I don’t exactly know what caused it but now I’ve to run

systemctl --user restart pipewire.service

every now and then to make my audio work. After some digging in, it seems pipewire is unable to locate my audio device properly. The issue repeats like every 5 minutes, if I’m constantly switching media source. Please help me resolve this. Thanks a lot and Happy new year!

Here is one debug screenshot that I’m unable to understand.

can you report

inxi -Fza

is pulseaudio installed ?

pacman -Qs pulseaudio

Here is

inxi -Fza
  Kernel: 5.15.85-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=909df00c-1213-480f-b680-ca1601cc3049 rw rootflags=subvol=@
    resume=UUID=a73ee5c2-6fe5-4c45-b882-06c5888ba67b loglevel=3 nowatchdog
    nvme_load=YES nvidia-drm.modeset=1
  Desktop: bspwm v: 0.9.10-41-ga510c36 info: plank, polybar vt: 7
    dm: LightDM v: 1.32.0 Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: LENOVO product: 82FG v: IdeaPad 5 15ITL05
    serial: <superuser required> Chassis: type: 10 v: IdeaPad 5 15ITL05
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN
    serial: <superuser required> UEFI: LENOVO v: FHCN41WW date: 05/17/2021
  ID-1: BAT0 charge: 47.8 Wh (100.0%) condition: 47.8/57.0 Wh (83.9%)
    volts: 12.8 min: 11.5 model: Celxpert L19C3PF5 type: Li-poly
    serial: <filter> status: full cycles: 368
  Info: model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
    microcode: 0xA6
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 3772 high: 3894 min/max: 400/4200 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3800 2: 3598 3: 3894
    4: 3788 5: 3800 6: 3790 7: 3800 8: 3707 bogomips: 38707
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: HDMI-A-1,eDP-1 empty: DP-1, DP-2, HDMI-A-2, HDMI-A-3
    bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce MX450] vendor: Lenovo driver: nvidia
    v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2022-12) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1f97 class-ID: 0302
  Device-3: Syntek Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-5:3 chip-ID: 174f:244c class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
    compositor: Picom v: git-982bb driver: X: loaded: intel,nvidia
    unloaded: modesetting,vesa alternate: fbdev,nouveau,nv dri: iris gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3200x1080 s-dpi: 96 s-size: 844x285mm (33.23x11.22")
    s-diag: 891mm (35.07")
  Monitor-1: HDMI-A-1 mapped: HDMI1 pos: right model-id: NCS 0x2275
    built: 2018 res: 1280x720 hz: 60 dpi: 108 gamma: 1
    size: 300x230mm (11.81x9.06") diag: 378mm (14.9") ratio: 4:3, 5:4 modes:
    max: 1024x768 min: 720x480
  Monitor-2: eDP-1 mapped: eDP1 pos: primary,left model: BOE Display 0x08e2
    built: 2019 res: 1920x1080 hz: 60 dpi: 143 gamma: 1.2
    size: 340x190mm (13.39x7.48") diag: 395mm (15.5") ratio: 16:9
    modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.3.1 renderer: Mesa Intel Xe Graphics (TGL GT2)
    direct render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  Sound API: ALSA v: k5.15.85-1-lts running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.63 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:7 chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: down
    bt-service: enabled,running rfk-block: hardware: no software: no
    address: <filter>
  Local Storage: total: 1.14 TiB used: 561.15 GiB (48.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530
    SDBPMPZ-256G-1101 size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 21110001 temp: 44.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-08Z10
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 1A05 scheme: GPT
  ID-1: / raw-size: 168.85 GiB size: 168.85 GiB (100.00%)
    used: 33.87 GiB (20.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 85.9 MiB (89.5%) fs: vfat dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-3: /home raw-size: 168.85 GiB size: 168.85 GiB (100.00%)
    used: 33.87 GiB (20.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 168.85 GiB size: 168.85 GiB (100.00%)
    used: 33.87 GiB (20.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 9.31 GiB used: 2.2 GiB (23.6%)
    priority: -2 dev: /dev/nvme0n1p7 maj-min: 259:7
  System Temperatures: cpu: 54.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 364 Uptime: 5h 41m wakeups: 1 Memory: 7.55 GiB
  used: 6.16 GiB (81.6%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: dpkg pkgs: 0 pm: pacman
  pkgs: 1150 libs: 262 tools: paru,yay Shell: fish v: 3.5.1 running-in: kitty
  inxi: 3.3.24

I am using pipewire-pulse

pacman -Qs pulseaudio
local/pavucontrol 1:5.0+r61+gee77d86-2
    PulseAudio Volume Control
local/pipewire-alsa 1:0.3.63-3
    Low-latency audio/video router and processor - ALSA configuration
local/pipewire-pulse 1:0.3.63-3
    Low-latency audio/video router and processor - PulseAudio replacement

because it says basically nothing … only that it is already running…
Same for the Hardware info it shows everything is running fine from the software side…

In 94% of cases you can solve audio issue by running pavuconrol and check the configuration tab about enabled and disabled devices.

Second would be to move configs out of the way and start from scratch (for audio)
mv ~/.config/pulse ~/.config/pulse.old
mv ~/.local/state/wireplumber ~/.local/state/wireplumber.old
if using pipewire-media-session it will be:
mv ~/.local/state/pipewire ~/.local/state/pipewire.old

and restart system or X

This is the only device that I have in configuration, and that seems up and running. I tried moving the config and restarted system, no luck.

i think i read about that your audio chip has issues with LTS kernel ?
tried booting into main kernel ? 6.1 ?

1 Like

Hi, I think that is the problem. Everything is running smooth on main kernel. I will test few more times with other media sources and get back. For the time being, if possible can you provide a source/reference for the issue. Thanks a lot!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.