Pipewire* 1:0.3.77-1 duplicates plasma-pa entries (on disconnect/reconnect) and breaks sound control

After the latest pipewire update I noticed that when my BT headphones would disconnect and I had to reconnect them, I was loosing volume-control while still hearing sound.

Turns out, on disconnect, the plasma-pa entries do not get removed.
On device reconnect a new entry is created and the volume control glitches out as a result of the multiple instances.

A relevan issue appears to have been opened on pipewire git for anyone that wants to track it.

Temporary fixes:

  • the suggested solution in the above issue:
    systemctl --user restart plasma-plasmashell.service
  • downgrading all pipewire-related packages to the previous version (1:0.3.76-2)
1 Like

Just from the issue you linked, this commit appears to fix the issue on Arch according to one user. Just have to wait for the Arch maintainer(s) to update the pipewire package on Arch and you should be all set. I wouldn’t flag the package out of date since it’s not a new release yet, but you could file a bug report here: https://archlinux.org/packages/extra/x86_64/pipewire/ to let the maintainers know they may need to cherry pick commits, or just downgrade pipewire and wait a couple days (maybe a week?) until a new release of pipewire is pushed out. Just a waiting game now really.

1 Like

Thank you for the update! :slight_smile:

I have personally downgraded for now to resolve the issue.

I created this post mostly as a heads-up to the EOS community (someone will run into the same issue sooner or later) to hopefully save others some time from needlessly investigating the same issue.

I’m not sure if its worth opening a bug report on Arch since the issue is already both reported and fixed (as you pointed) upstream. I’m confident that there will be a release soon enough judging by the past release frequency of pipewire.

1 Like

@peciwov
take a look here. It seems a kernel update fixed the issue

Just tried that following the other thread:

uname -r                                                                                                                                                                                                                               
6.4.9-arch1-1

Issue persists.

Uuuhm, i am on ltsand zenwithout the issue.
Sorry I am out

1 Like

For me as well.

I had the same exact issue. downgrading to 0.3.76 fixed it. thanks!

For me it is fixed with this kernel version

A new version of pipewire (1:0.3.77-2) has been released which includes the patch from upstream.

This hopefully resolves the issue for everyone, it did for me!

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.