Pip install not working on main EOS install but working on fresh EOS install

I wanted to install esphome using the instructions on their website. I ran pip3 install --user esphome but it failed with the error

ERROR: Failed building wheel for reedsolo
as well as
error: legacy-install-failure

complete log: https://0x0.st/o3K-.txt

The interesting thing is it works just fine on a fresh EOS install on another device of mine.

system is fully updated

inxi -Fxxc0z https://0x0.st/o3Ku.txt

Did you try installing esphome from the Archlinux AUR?

yay -S esphome

You may want to uninstall the pip version first.

There are also 5 other support packages for esphome in the AUR


Installing esphome from the AUR works, thanks!

Still, it frustrates me to know that something is broken with my python / pip installation…

1 Like

After some more experimenting it seems that the issue doesn’t lie with my system, but with the reedsolo pip package. After installing warpinator and it’s dependancies, pip install --user esphome doesn’t work. Without those added packages it installs fine.

Why this happens? No idea!

going with the AUR esphome package, as recommended by @Pudge, is probably the best call.

Glad you got it working. If an app is in the AUR, it is compiled specifically for Archlinux which is better than a generic offering.


Somewhat off-topic, but something I learned the hard way…

I’d recommend reading up on Virtual environments to create a self-contained Python environment in which you can install whatever you want with pip, without it conflicting with your system down the road.


yes arch wiki mentioned this only in a link to this:
But all of the default/alternative package tools for python can cause issues with already installed python packages or involved opens coming in as dependencies e.t.c

1 Like

Thanks for providing that link.

I read up on it and tested installing esphome in a virtual environment. It worked without issues. If something is only available with pip I’ll stick to using a virtual environment.

I was smart enough never to run pip as sudo so it was pretty easy to find the packages I installed with pip and uninstall them with pip uninstall $(pip freeze --user).


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.