Pinta paint app no longer opens after latest release

I downloaded it using yay -S pinta, its a simple paint style app but it no longer opens even after reinstalling it. This started after the latest update the other day.

Any ideas on troubleshooting it?

Thank you

This is the output I get in a terminal after trying to launch pinta. Seems you need to do an extra step, but please run pinta from a terminal and post the output in case you get a different error.

You must install or update .NET to run this application.

App: /usr/lib/pinta/Pinta.dll
Architecture: x64
Framework: 'Microsoft.NETCore.App', version '6.0.0' (x64)
.NET location: /usr/share/dotnet/

The following frameworks were found:
  7.0.18 at [/usr/share/dotnet/shared/Microsoft.NETCore.App]

Learn more:

To install missing framework, download:

Also, you could just install Krita, MyPaint, or Gimp and get the same features and whole lot more. MyPaint however, is painting and drawing only.

[admin@a51554 ~]$ pinta
You must install or update .NET to run this application.

App: /usr/lib/pinta/Pinta.dll
Architecture: x64
Framework: 'Microsoft.NETCore.App', version '6.0.0' (x64)
.NET location: /usr/share/dotnet/

The following frameworks were found:
  7.0.18 at [/usr/share/dotnet/shared/Microsoft.NETCore.App]

Learn more:

To install missing framework, download:

Crazy that all of a sudden people need an updated .net to run a 5MB paint app lol. Surely this doesn’t apply to linux??

Yeah, building apps with a dotnet runtime does that.

Probably can easily be fixed by installing the wine and wine-mono packages. Or don’t use that app anymore if you’re not attached to it.

No issues for me. I downloaded via yay -S pinta as well. Whether I open via applications or terminal…

Can you run the below and post the output please?

pacman -Q | grep -i wine

If it doesn’t show anything, then great, now I have no idea what could possibly cause this error and for the app not to run.


[wombat@endeavour ~]$ pacman -Q | grep -i wine
[wombat@endeavour ~]$
1 Like

Definitely odd, for sure!

So the app just decided not to run on the OP’s system, nor mine? Cool…


1 Like

Maybe try this one… Wanna see if there is some kinda version issue.

pacman -Qi pinta
[wombat@endeavour ~]$ pacman -Qi pinta
Name            : pinta
Version         : 2.1.2-2
Description     : Drawing/editing program modeled after Paint.NET. It's goal is to provide a simplified alternative to
                  GIMP for casual users
Architecture    : any
URL             :
Licenses        : MIT
Groups          : None
Provides        : None
Depends On      : gtk3>=3.24.21  dotnet-runtime-6.0  webp-pixbuf-loader
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 8.67 MiB
Packager        : Antonio Rojas <>
Build Date      : Tue 30 Apr 2024 03:52:02 PM CDT
Install Date    : Wed 01 May 2024 12:14:36 AM CDT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature
[wombat@endeavour ~]$

Was just about to post. Found the issue in a bug report. Yep. You have dotnet-runtime-6.0 and when I try to install it gives me dotnet-runtime-7.0 (aka the issue).

So the solution is to install dotnet-runtime-6.0.

yay -S dotnet-runtime-6.0
pacman -S dotnet-runtime-6.0

Here’s the bug report:

Update pinta to 2.1.2-1.
Try starting pinta. -> It shouldn't work.
Install package "dotnet-runtime-6.0".
Try starting pinta again. -> It should work.

Yep. Just tried it. Launched!

Seems someone made an error that added the incorrect runtime version. Will probably be fixed soon.

1 Like



I got the same results as unclespeelbinder. Nothing for the wine command, and the same result on -Qi.

I suppose installing a 65mb microsoft package to run a 5mb paint app is some kinda cruel joke, azpainter seems to have a lot more options for a 2mb app but looks like it was built on atari. you win some you lose some lol

Hey… A solution was posted.

Also, azpainter has not been updated since last year. And it’s weird but the URL for it on the AUR is kinda sketchy. Scratch that. It’s just Japanese-based is all. Should be fine.

yea i really do appreciate it, that’s what i meant by a 65mb microsoft package being the runtime package. when you say it should be fixed soon you mean it prob wont need this runtime 6.0 package to run? i’m just spiteful at this point that this thing worked fine for years then the linux overlords taketh away in the last update.

pinta isnt nearly as powerful as azpainter but its not built out of 10 pixels either. i need to consult my attorney on this one.

1 Like

No. It probably always had the dotnet runtime as a dependency, but when updating it to the new version, the maintainer probably typed a 7 instead of a 6 by accident. Easy mistake.

Yep. Confirmed it just now. It’s been using the dotnet dependency for years, but the maintainers keep switching which version pinta needs. Why? That’s outside of my understanding - probably related to features though.

I guess I never paid attention to whether it gets new features given that it’s such a basic app, but that makes sense. Thanks again!

1 Like

You’re welcome.

Please mark either your decision to use azpainter or installing dotnet-runtime-6.0 as the solution so that others may easily find out what to do.