Ping works with Wifi, not with Wired connection


I’m having problems connecting to some things… but not others.

Using my WiFi adapter: everything works (ping, firefox, pacman etc)
Using my wired network adapter:
firefox, pacman etc works fine
ping does not work

$ ping
PING (2a00:1450:4009:821::2004)) 56 data bytes
^C ping statistics —
7 packets transmitted, 0 received, 100% packet loss, time 6077ms

$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp5s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether 2c:f0:5d:34:39:56 brd ff:ff:ff:ff:ff:ff
inet brd scope global dynamic noprefixroute enp5s0
valid_lft 85959sec preferred_lft 85959sec
inet6 2a10:8702:0:3d00:2b76:3ffd:b29a:a8db/64 scope global dynamic noprefixroute
valid_lft 4294964492sec preferred_lft 4294964492sec
inet6 fe80::1d40:b0ce:44fc:1839/64 scope link noprefixroute
valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
link/ether fe:0f:4e:41:ce:a4 brd ff:ff:ff:ff:ff:ff permaddr 58:96:1d:58:a1:c9

05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 04)
Subsystem: Micro-Star International Co., Ltd. [MSI] Device 7c71
Flags: bus master, fast devsel, latency 0, IRQ 17
I/O ports at 3000 [size=256]
Memory at b4300000 (64-bit, non-prefetchable) [size=64K]
Memory at b4310000 (64-bit, non-prefetchable) [size=16K]
Kernel driver in use: r8125
Kernel modules: r8169, r8125

Ive tried switching from r8169 to r8125 but that hasnt solved it.

I also tried booting into my endeavourOS USB that i used for install… it has the same problem. Im out of ideas as to what to try next.

Any help would be greatly appreciated!

edit: Ive just tried on my windows dual boot and the same thing happened. I also have a raspberry pi on the same network with Manjaro on, the ping works fine on that.

Did you install a package for the r8125 module such as r8125 or r8125-dkms? You also don’t show what your WiFi actually is.

inxi -Na

$ inxi -Na
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8125
v: 9.009.02-NAPI modules: r8169 pcie: gen: 2 speed: 5 GT/s lanes: 1
port: 3000 bus-ID: 05:00.0 chip-ID: 10ec:8125 class-ID: 0200
Device-3: SteelSeries ApS Arctis 7 wireless adapter type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1:2 chip-ID: 1038:1260
class-ID: 0300

Did you install a package for the r8125 module such as r8125 or r8125-dkms?

Yes I installed r8125-dkms.

So, after trying to ping on Windows/USB Linux/etc and non of it working i tried changing where my ethernet cable is connected… Before it was plugged directly into my Router. I tried plugging it into my Wi-Fi Mesh and now everything works!

Clearly it isn’t a Linux issue… something is going wrong with my router (?). I have no idea what it could be so for now i guess ill just leave it as it is

1 Like

Okay and yes i see your WiFi is Intel iwlwifi.

Edit: Does the Ethernet not work at all if you didn’t install r8125-dkms. It either should run on the kernel module r8169 and if not the package you installed is correct but sometimes requires to blacklist the r8169 module. I’m not sure if your issue is related?

Ethernet works fine on r8125 and r8169… its just the ping that doesnt work. I tried blacklisting r8169 too.

Really strange issue… but like i said its all working fine now i’m plugging directly into my mesh wifi system


Strange. What exact ping command are you trying on WiFi? Also could you please use code tags around what you post to make it easier to read.

All I’m doing is:


What is the output?

Switched my Ethernet cable back to be directly into my router for this test.

Using Ethernet:

$ ping
PING (2a00:1450:4009:821::2004)) 56 data bytes
^C ping statistics —
10 packets transmitted, 0 received, 100% packet loss, time 9116ms

Using WiFi:
Screenshot from 2022-11-16 22-02-52

Must be some issue with getting out. When connected to Ethernet can you ping googles ip

Edit: also while connected to Ethernet can you ping your loop back address

Ahhh, yes i can ping googles ip and

Both work fine on Ethernet

Then you have a DNS issue.

Edit: Meaning it can’t convert the name to the IP

I don’t know much about DNS other than what it does…

Would i be right in thinking that maybe my router is handling the DNS incorrectly, but when i go through the Mesh WiFi its handling it instead?

It could be in the router settings or the network connection or maybe the DNS resolver? I’m not sure where the issue is happening? I just know that this is how you determine whether it is DNS or other network related problem.

Edit: Was it always this way or did it start at a certain point?

I just tried turning off ipv6 and that has fixed the problem, its now resolving the domain name correctly

So there you go. It’s a network issue caused by it trying to use ipv6.

That’s it :slight_smile:

Thanks for all your help on this, i can look into that now i know what the problem is

Just F.Y.I ipv6 is not 100%

the IPv6 adoption rate globally is around 34%,

Edit: I’m sure it depends on the hardware and settings etc.

You can ping ipv4 only using :

ping -4

or ipv6 only using :

ping -6