Pi 4 64 Bit USB BOOT headless

Hello guys,

after the official kernel/firmware is supporting usb boot, ive wondered if its also possible with the endavouros arm install?

ive tried some installs with the 64 bit arch iso (headless using it as a “server” but not got it to work. the 64 bit raspberry pi 3 64bit usb boot with arch worked flawless.

after some research i found a manjaro 64 bit arm minimal install iso and got it without problems to run, also working with emby v4l2 hardware transcoding. The latest 5.10 kernel is also running.

My question is, why is it working with manjaro but not with the original install? it is because the uboot?

is it possible with the endeavouros setup?

sorry for my bad english and explanation.

regards!

Yes it is possible to install Archlinux Arm 64 bit base install. It is as simple as running a script that will do it for you.

After that, you can run another script to install either EndeavourOS desktop with your choice of DE, or a simple headless server.


All the instructions/manuals are here

I would suggest starting by reading the EOS-desktop-instructions and EOS-server-instructions

As for booting from a USB device, you are on your own. There are plenty of tutorials on U tube on how to do this.

Pudge

2 Likes

I know all these scripts and manuals.
After i got it not working with arch, my question is if it is running on endeavouros since its running on manjaro.
im not a newbie or something else.
But watch in the archarm forums, there are many useres who got problems with usb booting arch.

And that is what my question is and i want to run my pi4 only via usb boot because it feels like 10 times faster with a ssd then a sdcard.

1 Like

Sorry, I didn’t mean to imply you were a newbie. I was simply trying to say what we offer and what we don’t.

I know what you mean about the speed difference. My daily driver is an Odroid N2+ and the difference between the uSD card and eMMC card is definitely noticeable. Especially read times.

I haven’t tried booting any Arm SBC from a USB device. But perhaps someone else here has.
I wish you well on your endeavour, let us know how it turns out.

Pudge

1 Like

Yeah,everything ok.
Maybe someone here got a solution.

Maybe Im going to try some things on the weekend with endeavouros.

Thought that maybe some one here got a solution.

1 Like

As far as I know, you will be the first person on this forum to try this. I guess that makes you a pioneer.

Odroid N2+ has 8MB SPI flash with boot select switch and Petitboot app installed by default.
One forum user was playing around with Petitboot but I really don’t know what became of it.

I looked around on the internet, found some that seem to work using Raspbian, but not much for Arch.

Pudge

USB booting with the new eeprom is working like a charm.
Ubuntu and Raspbian (both 64Bit is working) with the RPi4.

USB booting with a Raspberry 3 with arch is also working.

Everything used headless.

Arch with the rpi4 64Bit is not working so far. Maybe if they update they’re iso to the current state it will be work.
Maybe Im going to try to chroot into the os and update it before plugging it into the raspberry 4. I will report.

1 Like