Phantom windows just won't go

I have two nvme drives, one running eos hyprland, and the other had windows 11 until tonight i finally decided i no longer had any use for it and replaced the drive with eos kde plasma. os-prober still thinks their is a windows partition.
both drives have disable os-prober false uncommented in /etc/default/grub.
i’ve sudo grub-mkconfig -o /boot/grub/grub.cfg from both hyprland and plasma.

Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi

which in reality is the fat32 /boot/efi partition for eos. only advice i can find is about missing windows boot entries but mine wont go away.

i’m missing something simple probably. please advise.

UPDATE: i found a sneaky Microsoft directory in /boot/efi/EFI on hyprland. i murdered it then disabled the Windows boot entry in UEFI thinking it would fix everything…i somehow now have two Windows boot entries that go to blue screen and neither eos environment sees the other in grub but both are bootable by switching their order in UEFI… :tired_face:

1 Like

You would only need to enable os-prober in just one of the two EnOS’ systems.

Disable it in one of them by commenting it out again in /etc/default/grub and run the grub-mkconfig again to clean up the grub.cfg.

Also post the output of the following commands

sudo parted -l


sudo os-prober

from the os in which it is enabled.

Please post the terminal output as text. Copy, paste, highlight and press Ctrl-E to format.

sudo parted -l                                                                                      󰩐 
[sudo] password for kjo: 
Model: INTEL SSDPEKNU010TZ (nvme)
Disk /dev/nvme0n1: 1024GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name         Flags
 1      2097kB  1051MB  1049MB  fat32                        boot, esp
 2      1051MB  1006GB  1005GB  btrfs           endeavouros
 3      1006GB  1024GB  17.8GB  linux-swap(v1)               swap

Model: INTEL SSDPEKNU020TZ (nvme)
Disk /dev/nvme1n1: 2048GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name         Flags
 1      2097kB  1051MB  1049MB  fat32                        boot, esp
 2      1051MB  2039GB  2038GB  btrfs           endeavouros
 3      2039GB  2048GB  9449MB  linux-swap(v1)               swap
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0000,0004,0001
Boot0000* Windows Boot Manager	HD(1,GPT,e69d3234-57c7-40de-878a-ef9ebad8c852,0x1000,0x1f4000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000065000100000010000000040000007fff0400
Boot0001* endeavouros	HD(1,GPT,cb332a84-96f3-4432-8c0b-880de824ba26,0x1000,0x1f4000)/File(\EFI\ENDEAVOUROS\GRUBX64.EFI)
Boot0002* UEFI OS	HD(1,GPT,e69d3234-57c7-40de-878a-ef9ebad8c852,0x1000,0x1f4000)/File(\EFI\BOOT\BOOTX64.EFI)0000424f
Boot0004* UEFI OS	HD(1,GPT,cb332a84-96f3-4432-8c0b-880de824ba26,0x1000,0x1f4000)/File(\EFI\BOOT\BOOTX64.EFI)0000424f
sudo os-prober                                                                                                                                                                         
/dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi

plasma is drive ending in 20TZ
hyprland is drive ending in 10TZ

disabled os-prober and regenerated grub in plasma, and ran these commands from hyprland as advised.

We can try tackling the issue in bites and pieces to see where we land.

First, if I remember correctly, quite a while back when I was experimenting with multiboot system on Btrfs and Grub, the regular os-prober was incapable of detecting other systems. I had to use one specifically patched for Btrfs.

Back then I used Manjaro’s os-prober which has a fix for this. There is a package os-prober-btrfs in AUR but that one hasn’t seen an update for some time.

I would suggest to download Manjaro’s os-prober and build it yourself:

Download and extract the zip file. Go into the folder os-prober-master and open a terminal in there.
In the the terminal, run

makepkg -s

When it is done, install the package with:

sudo pacman -U os-prober-1.81-1-x86_64.pkg.tar.zst

Another option would be to skip the above and create a custom.cfg file in your Hyprland’s /boot/grub and copy the menuentries from your Plasma’s /boot/grub/grub.cfg into it. This will add boot menu entries from your Plasma to your Hyprland’s Grub boot menu.

I suppose this one is the EFI entry for your Hyprland. This uses the bootloader installed in the fallback path. You could try installing GRUBX64.EFI into the normal path if you want:

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=enos-hyprland

We can try removing Widows EFI entry:

sudo efibootmgr -b 0000 -B

Please consider the suggestions above and if there is anything unclear or you have other questions, post about it back here.

1 Like

thank you so much for the assistance, i will see what i can come up with trying these. i’ll update after.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.