Phantom output for displayport monitors

Hi, let me start by saying I LOVE EndeavourOS and have been using it for the past 10 months without want for distrohopping. Thanks for making this community amazing!

The issue -
My displayport monitors, incosistently, sometimes have a phantom output when rebooting or shutting down my computer. I have 2 displayport monitors (144hz) and 1 HDMI monitor (60hz), plugged into an AMD RX 6900 XT. Only the backlight is on for the affected monitors. The affected monitors are usually either one of the displayport monitors randomly, sometimes both, or sometimes neither. I can only temporarily resolve this by physically unplugging and replugging my monitor’s power cable. Last month I upgraded my GPU from a NVIDIA RTX 2070, and I had the same issue with that. Even did a fresh install of EndeavourOS right after upgrading it.

Context -
I’ve only experienced this in KDE plasma, both Wayland and X11. I tried GNOME for a week and didn’t experience the issue only after passing “amdgpu.runpm=0” in the kernel parameters in grub. Sadly that didn’t fix my issue when I switched back to KDE. My instinct is to post the issue here and not in the KDE forums, sorry if this is in the wrong place!

My output is still detected by xrandr:

Screen 0: minimum 16 x 16, current 5040 x 1920, maximum 32767 x 32767
XWAYLAND0 connected 1920x1080+0+207 (normal left inverted right x axis y axis) 600mm x 340mm
   1920x1080    143.88*+
XWAYLAND1 connected 1200x1920+3840+0 right (normal left inverted right x axis y axis) 320mm x 520mm
   1920x1200     59.88*+
XWAYLAND2 connected primary 1920x1080+1920+207 (normal left inverted right x axis y axis) 600mm x 340mm
   1920x1080    143.88*+

Monitor make/model: ASUS VG278

Side note, I know you can’t really use xrandr for wayland but I haven’t been able to find a similar tool for wayland. wlr-randr commands result in “compositor doesn’t support wlr-output-management-unstable-v1”

System info -

OS: EndeavourOS Linux x86_64 
Host: Z390 GAMING SLI 
Kernel: 6.0.2-zen1-1-zen 
DE: Plasma 5.26.1 
WM: kwin 
CPU: Intel i7-8700 (12) @ 4.600GHz 
GPU: AMD ATI Radeon RX 6800/6800 XT / 6900 XT 
Memory: 3235MiB / 15930MiB

This has been driving me crazy for the past 10 months and every time I look for an answer I can’t find a working solution. I would really love your input! Let me know if I can provide additional information. Thank you :heart:

Not sure if this is helpful?

This definitely could be my issue, my cables are cheap amazon orders from years ago. Just went and checked the reviews for the cable I ordered and I do see reports of pin 20 being active. I tried my girlfriend’s displayport cable that came in the box with her monitor, which is the same exact model monitor as mine, but I still had the same issue.

What I’ll do is order a cable that is confirmed to not have that 20th pin active and report back. Thank you so much for your reply :slight_smile:

It’s just a shot in the dark but there is definitely a difference in cables when it comes to specs and quality and whether they are certified to actually meet those standards.

Just installed brand new display port cables listed on as a certified products. Sadly still facing the same issue :frowning:

I did a bit more troubleshooting, I thought I might see a pattern between different DEs since I didn’t notice it last time I was on GNOME -

Format is
DE + if using 3rd monitor that is HDMI
phantom outputs/total reboots

Gnome no HDMI

Kde plasma with HDMI

Gnome with HDMI

Kde plasma no HDMI

Seems really random, I don’t think there’s any correlation between DEs, mixed input cables, or refresh rates with this issue.

And again I think to my girlfriend’s computer running Pop!_OS, previously ElementaryOS, that has my old graphics card and the same model monitor. I also don’t remember this being an issue when I was running Ubuntu back in December 2021. This leads me to think that the issue is coming from:

  1. A service that’s enabled/different by default between EndeavourOS and Pop!_OS, ElementaryOS, and Ubuntu
  2. Maybe my motherboard, or BIOS settings doing something weird during shutdown
  3. Somehow a difference with our systemd, since the phantom output happens during the shutdown process

I’m going to try dualbooting Fedora or Arch to see if the problem is present there, and if it isn’t maybe it’s worth submitting a bug ticket for.

EDIT: Issue persists in fresh installations (dual booting alongside Endeavour) of Pop!_OS and Fedora, so I’m stumped. Anyone have ideas? Maybe a BIOS setting that could be changed?

Shot in the dark here. What kind of power supply are you running?

Thanks for replying! I’m using an EVGA Supernova G+ 1000w PSU.

All good there. I keep thinking about this because it is boggling me. For good measure, you could try switching to the LTS kernel and see if it persists there.

That said I’m almost leaning toward monitors at this point. Seems your GF with the same monitor isn’t having the issue but it could be something in combination.

It is mind boggling. :thinking: :exploding_head:

Also happens with the LTS kernel :frowning:

My boss has said this same thing to me at work… I have a tendency to find the strangest bugs in software through seemingly no fault of my own. Maybe my PC build is cursed, making me a breathing edge case. My GPU was the first thing I upgraded but early 2023 I plan on upgrading all of the other parts of my PC. This time it will be with parts thoroughly researched to have as little issues as possible with Linux.

Well I guess that could potentially be considered a gift :slight_smile:

Have you tried updating your BIOS?

Have you checked memory settings. I read where xmp settings cause some issues. This is just info i read on some searches. I guess anything is possible. Hopefully you have separate power cords going to the GPU. And yes i would make sure the Bios is up to date.

Just updated my BIOS, I can’t believe I forgot that was a thing you should do. I had a BIOS version from 2018! Sadly it only took 3 reboots to see the issue again.

After the BIOS update and seeing the issue still, I saw the XMP setting was set to disabled. So I tried enabling whatever default profile they have for XMP and got the phantom output again after 2 reboots. Then I tried re-seating my RAM but that didn’t help either. I also tried plugging my monitors in to a different wall socket just in case with no luck.

Hopefully you have separate power cords going to the GPU

With my NVIDIA RTX 2070 I had a dedicated VGA+ 3x2-pin cable from my PSU plugged into it. But after my upgrade to my RX 6900XT I’m using the same cable’s series of 2x4 + 2x4-pin connectors from the same VGA+ cable.

You can try xmp profile which i use is one. I set my memory to 3200 Mhz. Not sure what Ram you are using. If you updated the Bios then you should check all your settings as it would most likely be set to defaults. I set the memory speed and xmp profile. Check secure boot and CSM are disabled.

My memory sticks are “Corsair vengeance LPX 16GB (2 x 8GB) DDR4 DRAM”, looks like the “auto” memory speed setting in the BIOS is configuring it for 3000Mhz, but setting it manually causes boot failures. CSM was enabled so I turned it off but I still saw the issue after a couple reboots. Secure boot is set to “custom” and “system”. Windows 8/10 support is set to “Other OS”.

Is your memory 3200Mhz. Doesn’t make sense that you would have boot failures if setting it manually. If it is 3200 Mhz you should be able to set it to that. Are you sure you are setting it in the proper place in the Bios?

The memory I have is 3000MHz, and when I manually set the XMP to 3000MHz yeah it results in a boot failure :thinking:

Here’s where I’m setting the MHz:

It’s saying 2113MHz on the right side after boot failure, with the XMP set to DDR4-3000. But if I set that option to Auto, it’ll show 3000MHz

Here’s the boot failure (sorry for the display port window covering some options)

Memory speed there is showing only 2132.82 Mhz?

Memory support for that CPU i7-8700 is DDR4 2666. Are you able to set it at that?

Edit: I have an Intel i7-8086K and it also is DDR4 2666 and that is the memory speed that i purchased and that is what i have it set to.

Thank you! I was able to set it to DDR4 2666, and I learned it’s based off of your CPU (or at least bottlenecked in my case) which I did not expect. So my CPU being limited to a DDR4 2666 memory type means the max clock speed for my RAM that my CPU can read and write from and to is 2666 MT/s? So when I was trying to start it with the DDR 3000 setting, the CPU to memory latency buffer was too high or out of sync or something?

Still seeing the issue but at this point I’m starting to accept that it’s just a very strange hardware issue that may only be “fixed” by waiting until my already planned new build. I really really appreciate the help and I would love to keep troubleshooting and learning BIOS stuff, just giving my thoughts on the original issue