Pgp-keys will not import

New install on an Asus GL753VE (used as a workstation because of broken internal screen)
I went for Plasma (for the first time in my life!). Everything vital works out of the box!! Very impressive I must say!!

I have only one problem. It is not possible to import keys when I install from aur and I have tried 5-10 packages so I suspect something is wrong!


hello,what is the software you want to install, what is the way you use it, thank you.

Ahh…Perhaps someone was working with github? :skull_and_crossbones:

In a terminal window, enter the following:
pacman -Q | grep keyring
archlinux-keyring 20200622-1
endeavouros-keyring 1-4
gnome-keyring 1:3.36.0-1

gnome-keyring may or may not be present depending on Desktop Environment, but the other two should be there.

EDIT : On second thought, I am not sure how or even if they utilize pgp keys in the AUR.


you first need to know the command it uses to install these aur packages.

1 Like

for your aur packets

Hi and thanks for answering!
I just installed Endeavour OS on this laptop (used as a workstation with external screen and external keyboard.)
I want to install linux-ck kernel and when I add repo I have to import their pacman-key.
“pacman-key -r 5EE46C4C && pacman-key --lsign-key 5EE46C4C
gpg: fetching from keyserver failed”

Same thing happens with some other packages too. As a matter of fact I haven’t been able to import one single key on this system yet!
I usually go with Openbox so I have no experience of Plasma at all. (Very beautiful though!) Is there something with Plasma and keys?


yay -S linux-ck

Yes I know but it will take 4 hours to build so I want the repo instead!


Hi again!
I think I solved it!
I read and followed.

From now on I am going to be better at searching for solutions before contacting you guys!!

Thanks for support!



For me it doesn’t work that solution, I have problems with importing keys for Spotify and Dropbox. Any other solution possible ? Or maybe I have forgotten something ?

I don’t know about dropbox (it installed over here), but Spotify has been flagged out of date for three weeks now, so that might be the problem. You can try spotify-dev.

It is with all keys it seems, no matter which package it is.

:: PGP keys need importing:
-> 931FF8E79F0876134EDDBDCCA87FF9DF48BF1C90, required by: spotify-dev
==> Import? [Y/n]
:: Importing keys with gpg…
gpg: keyserver receive failed: Algemene fout
problem importing keys

You can try to update your mirrors, use the button in the welcome app, it’s much easier.

hello, often the key server does not respond

Updating mirrors did not work, but I found another way:

Before installing the package first manually installing the key by this:

gpg --keyserver --recv-keys

And then adding the key after that, and that worked for me. And then installing the package. Probably not the most beautiful way, but it is a solution, hopefully temporary.


Hello all…
I have looked and looked…Followed links…Checked wikis…Updated…Not updated…And basically tried anything and everything I could think of…
I am a once and probably future user of Endeavour…Currently using a vanilla XFCE off an ISO by EZARCH…
The problem was the same on Endeavour…So I hope someone has a solution here…
The problem…

PGP keys need importing:
-> EA0A77BF9E115615FC3BD8BC7653B940E494FE87, required by: mullvad-vpn
==> Import? [Y/n]
:: Importing keys with gpg…
gpg: keyserver receive failed: General error
problem importing keys

Again…I have tried…No luck yet…
Any help would be greatly appreciated…
Recognizing that in the world we are currently living this is a tiny problem…
Peace and health to all…

No this is not solved!
I managed to import keys for linux-ck but I have had problems after that !
This is not an Endeavour OS problem!!
All Arch-distros (that I know of!) have this problem and it seems like there are too many solutions right now!! (but no permanent one!) Do not give up this great distro (with a wonderful community) yet!!
My guess is that is has to do with key-servers.


Thank you for the quick reply…Much appreciated…
I haven’t abandoned Endeavour, just as is my wont, taking side trips…
It is a wonderful community…
Time fixes everything…Or not… Hahaha
Thanks …
Peace and health…