Personalization of my ISO

Is possible to edit my Cassini Neo ISO memstick and include these tools?

snapper btrfs-assistant btrfsmaintenance

Also, would be possible to copy my snapper conf files along with btrfsmaintenance.conf to the ISO ?


you can build your own and add the tools to the package list for the ISO:

problem is that two of them are not in the repos so you will need to use this:

and add manually builded packages there to get installed

But the changes to the ISO will only be available on the live session… and offline install could keep the packages online installs using package lists from inside calamares package…


Thanks @joekamprad, I’ll perform some tests.
Really appreciated.

You mean the user_pkglist.txt on the ISO in live mode? I read somewhere that no packages from the AUR are possible there. If that is no longer true, I will immediately adjust my user_pkglist.txt.

no this is a user feature on the ISO itself I was talking about building a custom ISO from the sources.
There is the option to add manually builder packages to get installed for the live session… we use this on testing calamares but it works for others too…

ask me if you need some info :wink:

1 Like

One of those is an AUR package so it might require a bit more than just adding it to the list.

1 Like

This is also one (advanced) way to customize the install without rebuilding the ISO (just use the latest available ISO):

eos-welcome --ni="URL-to-your-user_commands.bash"

More info here:


@dalto added this as info too later.

1 Like

Perhaps with phase 2 using a local folder with the packages I want?
Then, instead of using pacman or yay, I could just use tar -zxvf package;./configure;make;make install

all depending on your goal… if you need the packages for rescue from the livesession only it would be good top go to only have them on live session… if you are okay with offline install you could simply use your Desktop as livesession on your ISO and install it offline… in case you need to reinstall

My goal would be to have a “restore btrfs ISO” ready for use, with some btrfsmaintenance tools in case a scrub or something like that shows necessary.

Everything aligned with my current setup, with my configurations.

Something to make this process faster, like plug and play then just open btrfs-assistant and restore.

- Install snapper, btrfs-assistant and btrfsmaintenance
# pacman -S snapper
$ yay -S btrfs-assistant btrfsmaintenance
- Check your drive mapping and mount it accordingly. 
# fdisk -l
- Mount and copy config files.
# mount -o subvol=@ /dev/sdb2 /mnt
# mount -o subvol=@home /dev/sdb2 /mnt/home
# cp /mnt/etc/snapper/configs/* /etc/snapper/configs
# cp /mnt/etc/conf.d/snapper /etc/conf.d/snapper

Obs: You can rollback to any snapshot now, just open btrfsassistant, choose the snapshot and restore it.
If your kernel changed since that snapshot, you need to chroot and reinstall kernels.

ARCHCHROOT below only if the kernel version is different:
# mount -o subvol=@ /dev/sdb2 /mnt   (You already mounted this in the step above)
# mount /dev/sdb1 /mnt/efi
# arch-chroot /mnt
# sudo reinstall-kernels
- Reboot the system

yea so you would be fine by adding the packages to the folder I mentioned before… to have them installed on the ISO itself…

1 Like

Great, thanks :slight_smile:
I have free time today, so I’ll definitely try this and update here in case of success…

1 Like

The problem is calamares calls user_commands.bash as root, and yay or makepkg do not work with that.
But I guess there are many ways to work around that limitation.

1 Like

Just wanted to see how BTRFS-assistant behaves on LiveSession seems to work so feel free to check this ISO ***

Downloading now, will test as soon as the download finishes :slight_smile:

If you are in Europe download should be fast,

South America: Burning the ISO, tests pretty soon


It worked flawlessly and man, I have to say, I’m feeling really VIP right now =)
That wallpaper is my wallpaper from now on =)

To test, I restored a snapshot from 40 minutes ago, it was fast!!!
All I had to do was to mount my @ subvolume and copy my snapper config files to the right folder, start btrfs-assistant and restore :slight_smile:
btrfsmaintenance also worked without any changes, just selected the /mnt subvolumes and pressed save.
This action generated the config file and after that, scrub, balance and defrag runs without problems :slight_smile:

Edit: I also mounted /var/log and /var/cache, so btrfsmaintenance could work in those subvolumes.
But for a system restore, those mounts wouldn’t be necessary (I only have root and /home snapper configs).