PDF Printing: Preview looks different

Hi All,

The solution may be trivial but I am not a typography expert, so turning to the community’s collective knowledge hoping someone could assist me.

Below you see the screenshots of the original document view in Okular and the print preview of the same document. The print is usable and readable but still it puzzles me what I may need to do next time to print PDFs properly as seen on the original display. How come it displays fine but the print is messed up?


Thank you for any help you could provide!

Does the actual printed copy look like the preview or the original document?

Doesn’t it have to do with the difference in fonts you have in the settings in your browser and in the system?

Good point. I should have mentioned that the actual physical print is the same as the print preview.

I am not sure if I understand. The two screenshots are both from Okular of the same document on the same computer: one is how you see what open the file and displayed in the application and the other is the print preview in Okular, too.

Then ignore my question, I thought the browser opened the second one.

No problem and thanks for your response. Logically my issue has something to with fonts installed and how, where and when they are available… My assumption about PDFs in general that you see and print them as was exported to this format. My theory failed, I guess. :slight_smile:

1 Like

What printer driver are you using?

Can you try another PDF viewer? Check this old post on Linux Mint Forums.

Try File → Properties and there should be a tab to check what fonts are used in document, so you can search for them and install

I thought you should never need to install fonts for a pdf? There are a set of base fonts that all pdf viewers should include and any other fonts have to be embedded in the pdf.

Unless it is a requirement of the printer driver.

1 Like

I am using it through CUPS installed locally as I could not find a proper driver to my printer, which would utilize all features (mostly duplex printing). The printer was set up months ago and I cannot recall though having similar issues before.

Awesome! Thank you! That was the solution.
Before


After

I never would have thought that I need the fonts installed for the printing if it can display properly.

Thanks again and have a great day!

This solution makes no sense… Why would you need fonts to print a PDF? The whole point of PDF is portability, that’s what P in PDF stands for.

3 Likes

I agree and I am still puzzled but it still worked. Anyone knows the reason, please feel free to shed some light on it.

1 Like

That’s a suggestion from Okular Handbook (page 27):

File → Properties (Alt+Return)
Display some basic information about the document, such as title, author, creation date, and
details about the fonts used. The available information depends on the type of document.
NOTE
Please pay attention on the information about substituting font in the Fonts tab of the Properties
dialog. Many problems with font rendering can be solved by installing of the substituted fonts.

My guess is that some PDF files doesn’t have the fonts embedded and that’s why you need to install them. The answer to this thread explain some common causes for the issue.

At the same time, it’s weird, because the document looks fine before trying to print it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.