PCManFM: Open and save files with Onlyoffice?

Is it just me, or do OnlyOffice works such as that you have to open files from within the suite itself, with the file picker, to be able to work on them?

When I open a file from PCManFM, it just displays an empty word document. No matter if it is an excel file, presentation or word document.

I’ve been searching the forum, but didn’t find an answer.

could you give some info about what DE you use and how you installed it?


I use Fluxbox. Truth be told, it is a bare installation on Arch. But I figured this shouldn’t matter and that it was an application issue.

I tried both the flatpak and the AUR, and they act the same. Now, I have the AUR onlyoffice-bin version.

not with the application itself in general… and also yes… it does not matter to get support also if you do use “pure” arch :wink: but the info is helpful… as EndeavourOS is preinstalling packages for Desktop experience you may miss on a pure arch install …

If I install onloffice on EndeavourOS XFCE4 install I do not have the issue (the bin from AUR)

I can double-click files and it opens oo and associations are set automatically too…

Could be Fluxbox do need some mimetype setup done manually or to install some helping packages…

OK, thanks!

At least from what you are saying, I’ve got a general direction to go to solve this.

Permission shouldn’t matter with the flatpak, as I did

flatpak override --filesystem=host net.cozic.joplin_desktop

and in any case I copied a couple word and excel files to /home/downloads.

Association seems to have been set automatically.

It opens any office file from the file manager, but just displays an empty onlyoffice word document, instead of the file I actually clicked on. I have to open files with the internal onlyoffice file picker, to actually open them.

When and if I solve this, I’ll report the solution here.

Yes, I’m working on doing an (almost) exact replica of EOS on Arch, with a few adjustments. Much fun and very informative!

For what it is worth, I opened PCManFM with the terminal, and then navigated to a Microsoft Office Word file, and double clicked it. As usual, Onlyoffice just diplays an empty Onlyoffice word document.

This is the output in the terminal:

** (pcmanfm:9641): WARNING **: 12:41:55.574: terminal alacritty isn't known, consider report it to LibFM developers
/usr/bin/onlyoffice-desktopeditors 'file:///home/vlad/Downloads/BAVER2010%20arbeidskrav.docx'
QLayout: Attempting to add QLayout "" to CTabBarWrapper "tabWrapper", which already has a layout


is the place to sneak-peak packages … it bis sorted in categories so you can check easy

1 Like

Great, thanks!


should be supported

I have no problems when opening the file from Onlyoffice itself, with its own file picker
Perhaps this last line from the output gives a clue?

Attempting to add QLayout "" to CTabBarWrapper "tabWrapper", which already has a layout

does pcmanfm showing onlyoffice in the rightclick menu?

this is mainly something xdg-open / mimetype related that is not installed or setup

1 Like
[12:54:01] joekamprad :: SLIMSHADY64  ➜  ~ » yay -Qs xdg                                                                                           127 ↵
    automatic generate WM menu from xdg files
local/libcanberra 1:0.30+r2+gc0620e4-2
    A small and lightweight implementation of the XDG Sound Theme Specification
local/libxdg-basedir 1.2.3-1
    An implementation of the XDG Base Directory specifications.
local/python-pyxdg 0.28-1
    Python library to access freedesktop.org standards
local/xdg-dbus-proxy 0.1.4-1
    Filtering proxy for D-Bus connections
local/xdg-desktop-portal 1.16.0-1
    Desktop integration portals for sandboxed apps
local/xdg-desktop-portal-gtk 1.14.1-1
    A backend implementation for xdg-desktop-portal using GTK
local/xdg-user-dirs 0.18-1
    Manage user directories like ~/Desktop and ~/Music
local/xdg-user-dirs-gtk 0.11-1 (gnome)
    Creates user dirs and asks to relocalize them
local/xdg-utils 1.1.3+25+g8ae0263-1
    Command line tools that assist applications with a variety of desktop integration tasks
local/shared-mime-info 2.0+155+gf4e7cbc-1
    Freedesktop.org Shared MIME Info
1 Like

It seems the problem could be related to Fluxbox, and just an incompability with Onlyoffice.

When I start Onlyoffice from the terminal, the output is this:

[vlad@archlinux-stue ~]$ onlyoffice-desktopeditors
QLayout: Attempting to add QLayout "" to CTabBarWrapper "tabWrapper", which already has a layout
[vlad@archlinux-stue ~]$

When I google that, I end up at the Onlyoffice support site. A guy had the same problem on a tiling window manger. The answer provided seems to be this:

Unfortunately, Desktop Editors app is not adapted to work with mentioned spectrwm window manager, so to use it I’d recommend you to install KDE or Gnome.

OK, thanks!

I’ll digest that and investigate it later this evening!

Yes, it does

Thnaks, I’ll look into that!

i mean it does not say only because some one say install kde or gnome that it ios not possible to get it working :wink:

OK, I somehow suspected I had to relate to the xdg stuff at some point.

I’ve been avoiding it because I seemed to do fine without. But it seems the time is here to face it, with some beer and coffee and Dutch courage later this evening.


Some small progress.

I’ve been reading about xdg, mime and such. It will take a while more to actually understand it more deeply, but I’ve done some experimenting. Everything seems OK with regards to default apps and such.

I installed Thunar. Thunar works with Onlyoffice as expected. When I click on a ms word file, it opens it and I can see what is written in it.

PCManFM does not do this. when I click on a word file, it just displays a empty word document. Same goes for excel and other office formats.

I loaded community EndeavourOS Openbox in a virtual machine. It comes with Thunar. I installed Onlyoffice from the aur. Thunar works with onlyoffice documents as expected.

I then installed PCManFM in EOS Openbox. PCManFM on EOS Openbox behaves excatly as it does on my Arch, with regards to Onlyoffice documents.

Same result in the Official EOS on a live iso.

I’m at a loss.