pCloud doesn't start on startup anymore


Anyone use pcloud on EOS? I noticed last few weeks that pCloud doesn’t start when I start EOS. This worked without problems in the past. When I start it manually it works fine.

In Pcloud general settings I have checked the option to start pCloud drive on system startup.

I tried to add it manually with:
sudo systemctl enable pcloud.service

but I got the response:
Failed to enable unit: Unit file pcloud.service does not exist.

If I run pcloud in console I get this:

(node:3523) UnhandledPromiseRejectionWarning: Error: Cannot find module '../net'
    at Module._resolveFilename (internal/modules/cjs/loader.js:602:15)
    at Function.Module._resolveFilename (/tmp/.mount_pcloud4O0ITf/resources/electron.asar/common/reset-search-paths.js:35:12)
    at Function.Module._load (internal/modules/cjs/loader.js:528:25)
    at Module.require (internal/modules/cjs/loader.js:658:17)
    at require (internal/modules/cjs/helpers.js:20:18)
    at Object.get [as net] (/tmp/.mount_pcloud4O0ITf/resources/electron.asar/browser/api/exports/electron.js:11:16)
    at u (/tmp/.mount_pcloud4O0ITf/resources/app/node_modules/@aptabase/electron/dist/main.cjs:2:1507)
    at new Promise (<anonymous>)
    at d (/tmp/.mount_pcloud4O0ITf/resources/app/node_modules/@aptabase/electron/dist/main.cjs:2:1422)
    at q (/tmp/.mount_pcloud4O0ITf/resources/app/node_modules/@aptabase/electron/dist/main.cjs:2:1887)
(node:3523) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:3523) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

Any idea how to fix this?

Are you sure it’s not running?

Try this:
Make sure pCloud is closed by checking your preferred system monitor, log out, log back in, then open your system monitor again, and search for pCloud in the list.
→ You may need to give it about 30 seconds after logging back in.

I used to have a similar issue, and it turned out that it was running, but the GUI wasn’t launching.

pCloud folder is empty before I start it manually. All works fine except that doesn’t start automatically. I also noticed that another pcloud application appeared. Weird… probably some update did this… but would be great if there is a way to fix it.

Not sure what this means.

It’s an Appimage, it creates multiple processes for sandboxing and interacting with your system. Assuming you meant multiple processes.

Did you actually do what I suggested you to try? I’m not sure from your response.

Folder that is populated with all files from the cloud is empty before I start pCloud. This simply means that pCloud doesn’t start. If I run it manually that folder displays all files I have in cloud which means that the application alone works great… just doesn’t start automatically

I don’t mind if there is multiple process but I don’t need multiple shortcuts to start pCloud. I can delete one, but I don’t know why are located in different locations.

Oh, I understand now.

It kinda looks like you have it installed twice. Check with the command below:

pacman -Q | grep -A 2 -E pcloud
[uros@uros-EOS ~]$ pacman -Q | grep -A 2 -E pcloud
pcloud-drive 1.14.6-1
pcre 8.45-4
pcre2 10.44-1
[uros@uros-EOS ~]$

Yep. It is weird, like you said. You should be able to hide one without actually deleting it. I’d hide the one in /opt/ instead of the one in /usr/.

Then try to launch it. If it doesn’t work, do the reverse.

As far as autostarting is concerned, try pointing to the file that works more directly by using its entire path.