[PCE-AC88] Wifi Trouble at Installation

I am looking to install EndeavourOS onto my machine as the primary OS

At installation I am unable to connect to the internet(WIFI) and install EndeavourOS.

Here is my Adapter: PCE-AC88 - AC3100 Dual Band PCIe® Wi-Fi Adapter

I do remember seeing that there are some incompatible WIFI adapters for linux but, I don’t know how to fix this issue. Please let me know, thanks in advance.

First: welcome to the forum!
Second: I do not have your wifi adapter so my answer is only theoretical
After googling “Arch Linux PCE-AC88” I found out that you have to do two different things to make it run:

  1. Install the correct driver for Broadcom chipset.
  2. You have to extract/download the correct firmware for the chipset, because the one you need seems not to be included in linux-firmware.

I would install EOS with a different LAN or wifi and afterwards make your wifi adapter run.

1 Like

Just to verify, which one is it? Can’t connect to wifi, or can’t access resources on the Internet?

This sounds like the issue I’ve had. Basically, the Broadcom adapter is supported by a couple of different drivers, most notably ‘b43’ which is a reverse-engineered driver, and ‘wl’ which was written by Broadcom. The ‘wl’ driver is the preferred one in most cases and its installation disables the automatic loading of the other one.

The wl driver is also loaded by the kernel on the installer disk but, personally, I’ve never gotten that one to work correctly. Fortunately, there are a couple of options:

  1. Install EndeavourOS using the “offline” installer. This installs an XFCE4-based desktop which will include a wl driver that will work on reboot.

  2. Do the initial install using a wired Ethernet connection to your modem/router.As in the first case, a working driver will be installed.

  3. If you can grab a copy of /lib/firmware/b43 from another Linux system, copy that directory to a flash drive other than the one with the EOS installer. Boot the installer. Once in the installer Live CD, insert the drive with the b43 firmware into another USB port. In the file manager, open a terminal in that drive and type the following commands:

$ sudo -s
# rmmod wl
# cp -r b43 /lib/firmware
# modprobe b43

At this point, you should be able to connect to the network normally.

1 Like

@rell
It’s best to know exactly what chip the wifi adapter uses. If you could post the following output from:

inxi -n

I just checked the EOS-forum and I found following thread:

ASUS PCE-AC88 Wireless Adapter Not Working

Maybe there is a solution for you.

1 Like

Network:
Device-1: Broadcom driver: N/A
Device-2: Intel Ethernet I225-V driver: igc
IF: enp8s0 state: up speed: 1000 Mbps duplex: full
IF-ID-1: enp1s0f0u4c4i2 state: down

I have access to LAN where I have installed the b43-firmware through yay but I do not know how to activate it or if it activates on its own. I know my WIFI adapter is not on because the blue signal light in the back is not blinking/on

my issue was that I could not connect to WIFI since I did not have the correct driver installed for installation. I have since installed EOS through LAN and am trying to figure out how to activate the B43-firmware I have just installed onto my sys through yay

It shows it’s a broadcom but module isn’t loaded. It should be using the kernel module. Uninstall broadcom-wl and or broadcom-wl-dkms if these are installed and reboot.

1 Like

ok I will try this, after how should I connect to the wifi network? when I try typing wifi-menu nothing comes up.

If the wifi is working you should be to click on the network icon and see your wifi and connect to it.

Edit: Not sure what desktop you have. On Kde i have to enable wifi first as i have it disabled.

It worked thanks alot!

1 Like

Thank you all for the help try a combination of your solutions helped me solve the issue!

1 Like

Please credit the post that helped you the most by marking that as the solution, you can undo the title edit after that.

For any user that stumbles upon this with the same issue here is a working solution:

1.) First thing that I did is directly link to my router via LAN cable to have a connection and followed the normal installation.

2.) after installing and being in the main boot I installed the AUR helper yay and did the command sudo yay -S b43-firmware

3.) I somewhat followed @marteng69 solution to identify what type of broadcom driver I had. To find this I use the following command

lspci -vnn -d 14e4:

which returned the following output for me.
I went back and got the output after the problem was resolved so the bottom two: kernel driver and kernel modules may look different to you

05:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries Device [14e4:43c3] (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device [1043:86fb]
	Flags: bus master, fast devsel, latency 0, IRQ 66, IOMMU group 13
	Memory at fc000000 (64-bit, non-prefetchable) [size=32K]
	Memory at fb800000 (64-bit, non-prefetchable) [size=8M]
	Memory at e2400000 (64-bit, prefetchable) [size=4M]
	Capabilities: <access denied>
	Kernel driver in use: brcmfmac
	Kernel modules: brcmfmac

This allowed me to identify that I had a [14e4:43c3] device which tells me I need the brcmfmac driver
https://wireless.wiki.kernel.org/en/users/drivers/brcm80211

3.) After installing the firmware and knowing which driver I needed
I then initialized my driver by using the following commands found in the post linked by @marteng69 ASUS PCE Wireless Not working and as suggested by @jruschme

sudo rmmod wl
sudo modprobe brcmfmac 

4.) Next I then followed @ricklinux 's post

It shows it’s a broadcom but module isn’t loaded. It should be using the kernel module. Uninstall broadcom-wl and or broadcom-wl-dkms if these are installed and reboot

using the command

sudo pacman -R broadcom-wl or broadcom-wl-dkms

After rebooting I was able to see local WiFi networks in the top right where the connection tab is located and my issue was resolved.

1 Like

You don’t need

to use

The actual end-result solution was listed in the other thread that was linked:

It’s also detailed on https://wiki.archlinux.org/title/Broadcom_wireless

2 Likes

This why i always want to know what chip the wireless device is using so i can determine what module it’s supposed to be using.

1 Like

Got it thanks, I updated the solution. Just glad everything is fixed.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.