PC starts again immediately after I have sent it to the sleep mode

My pc starts immediately after i sent it to sleep mode.

Welcome to the EndeavourOS forum @Browe

You’re going to have to give a lot more information than that to help us find the cause…

From the A friendly intro about our community rules and tips for the forum topic:

“To receive the proper and quickest way for a solution to your issue, please give us a complete as possible description of your situation. This means mentioning your hardware specs, which DE you’re running, what you were doing before the issue appeared and post logs. (To do that please read this link.)”

OK, sorry

This is my Hardware: System:
Kernel: 6.2.12-arch1-1 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.27.4
Distro: EndeavourOS
Type: Desktop Mobo: Gigabyte model: B550 AORUS ELITE V2 v: x.x serial: N/A
UEFI: American Megatrends LLC. v: F15 date: 01/12/2023
Info: 8-core model: AMD Ryzen 7 5800X bits: 64 type: MT MCP cache: L2: 4 MiB
Speed (MHz): avg: 2500 min/max: 2200/4850 cores: 1: 3800 2: 2200 3: 2200
4: 2200 5: 2200 6: 2200 7: 3800 8: 2200 9: 3800 10: 2200 11: 2200 12: 2200
13: 2200 14: 2200 15: 2200 16: 2200
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT]
driver: amdgpu v: kernel
Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: amdgpu
unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu
resolution: 1920x1080~60Hz
API: OpenGL v: 4.6 Mesa 23.0.3 renderer: AMD Radeon RX 6750 XT (navi22
LLVM 15.0.7 DRM 3.49 6.2.12-arch1-1)
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel
Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
Device-3: C-Media VIRO Plus type: USB
driver: hid-generic,snd-usb-audio,usbhid
API: ALSA v: k6.2.12-arch1-1 status: kernel-api
Server-1: PipeWire v: 0.3.70 status: active
Device-1: Intel Wireless-AC 9260 driver: iwlwifi
IF: wlan0 state: up mac: 70:1a:b8:09:23:83
Device-2: Realtek RTL8125 2.5GbE driver: r8169
IF: eno1 state: down mac: 74:56:3c:39:a0:72
Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
Report: rfkill ID: hci0 state: up address: see --recommends
Local Storage: total: 465.76 GiB used: 270.4 GiB (58.1%)
ID-1: /dev/nvme0n1 vendor: Kingston model: SNV2S500G size: 465.76 GiB
ID-1: / size: 456.41 GiB used: 270.32 GiB (59.2%) fs: ext4 dev: /dev/dm-0
Alert: No swap data was found.
System Temperatures: cpu: 34.5 C mobo: 23.0 C gpu: amdgpu temp: 35.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Processes: 384 Uptime: 4m Memory: 15.52 GiB used: 2.96 GiB (19.1%)
Shell: Bash inxi: 3.3.26
I’m using KDE Plasma.
The only thing i did was pressing the sleep button. Btw the sleep mode did never work.

Post output of this command:

systemd-inhibit --list

NetworkManager 0 root 1004 NetworkManager sleep NetworkManager needs to turn off networks delay
UPower 0 root 1179 upowerd sleep Pause device polling delay
PowerDevil 1000 bridebrow 1425 org_kde_powerde handle-power-key:handle-suspend-key:handle-hibernate-key:handle-lid-switch KDE handles power events block
Screen Locker 1000 bridebrow 1347 ksmserver sleep Ensuring that the screen gets locked before going to sleep delay
signal-desktop 1000 bridebrow 1551 signal-desktop sleep Application cleanup before suspend delay

5 inhibitors listed.

I’m also running KDE Plasma (on different hardware) and my output of systemd-inhibit --list is the same as for you, with the exception of the line for signal-desktop.

When you say “Btw the sleep mode did never work” what do you mean? Sleep has never worked on your system, no matter what distro or desktop environment you had installed?

What happens when you select “Sleep” from the Kickoff menu, or press Ctrl-Alt-Del and then select “Sleep”?

I have tried Manjaro Linux and EndeavourOS but on both distros it didn’t work.