Password issues

I’m able to login with my password and even install something with “yay”. However whenever I try to install something else or do anything else that requires password it no longer works. I restart and the same thing happens. Able to login, first attempt at something works. Then password no longer works.

And yes I’ve tried resetting the password but it requires the old password which still doesn’t work… :smile:

1 Like

i’m confused:

doesn’t yay ask for your password when you use it to install something?

Well, but just a shot in the dark. Maybe a keyboard layout issue. Your desktop environment is set to another layout than your display/login manager. So you can login, but with the layout being different afterwards, you are not typing what you think you are :sweat_smile:

After rebooting 2 more times it seems to be working again. I dont see any issues with the keyboard layout. If anyone has any additional input on this in case it happens again. Please comment. Thanks.

as i said - it was just a shot in the dark… can be problematic when using special characters for your password and the keyboard layout is different.

Anyway - glad its working for you now.

If this happens again, check the output of faillock - it’s possible you’re trying the password incorrectly and locking yourself out?

I found this thread because I had this issue today. After booting up my laptop I did sudo pacman -Syu and it worked fine. There were no updates available. I just closed the terminal emulator. After few minutes (I think more than 15 in this case) I tried to run another command with sudo, it asked me for my password again and the response was “Sorry, try again.” I thought that I had caps-lock on or something like that, but no. Keyboard layout was also fine and I even tried typing my password in text editor to check that and it was okay. I did it 3 times “wrong”.

What I did to unlock myself.

  1. faillock - it shows me that I put wrong password 3 times
  2. faillock --reset - to unlock it
  3. failock - I run it again to confirm that there is no info about mistype password right now
  4. Everything works again.

Still don’t know… but I’m like 99% sure that I was typing my password correct from the beginning.

2 Likes

I kept having to reboot when it would happen. An unrelated issue came up with my dual boot so I ended up reinstalling it, I have not run into the issue since. I know this doesn’t help but that’s where I ended up.

1 Like

This happens to me too. Usually login in and out solves it too.

I never had this issue again since then but today I found another report about it in r/archlinux

Here it is

1 Like

Wondering, are you guys using gnome DE?

In January I had a problem in manjaro were after suspend I could not login to my session anymore. It just wouldnt pick up my password. Maybe totally unrelated but very strange bug.

A suggestion, could you try an alternative terminal shell, just install another to try?

Yes. I use GNOME. Actually it was only one time issue and never happened again to me.

BTW, after some research I found similar posts about it from years '12, '17 in Arch Linux forum. In one case somebody had problem because of corrupted /etc/sudoers file, but in another it was related to something called “pam/pambase” and reinstalling this thing was a solution. In the reddit link I posted above there is also something related to “pam/pambase” errors from journal.

For now, everything is OK and I don’t feel confident enough to mess around these things until absolutely necessary.

Old posts from Arch Linux forum which I found:
https://bbs.archlinux.org/viewtopic.php?id=142720
https://bbs.archlinux.org/viewtopic.php?id=142941
https://bbs.archlinux.org/viewtopic.php?id=143487
https://bbs.archlinux.org/viewtopic.php?id=142729

1 Like

Today it happened again. Now I’m 100% sure that I was typing my sudo password correctly.
So, I just opened gnome-terminal to run sudo pacman -Syu. It asked for password. Everytime it was “incorrect” and Sorry, try again. message was received. I did faillock --reset and problem was solved, even running the same terminal emulator session.

What unusual I have from my logs when error occurs:

22:10:38 sudo: pam_unix(sudo:auth): auth could not identify password for [myusername]
22:10:38 sudo: pam_unix(sudo:auth): conversation failed

After faillock --reset it works as normal again.

2 Likes

Show:

$ cat /etc/pam.d/sudo

I have had this issue spontaneously pop up maybe… three times since I switched back to Arch from Fedora in November. Suddenly the password doesn’t work for sudo in terminal or in GUI prompts but I can log in, and i can use sudo switching to TTY.

The only thing that helps is rebooting.

cat /etc/pam.d/sudo
#%PAM-1.0
auth include system-auth
account include system-auth
session include system-auth

Also keep in mind that it also tracks every time you cancel a sudo prompt, and stores those as “failures” for 15 minutes.

1 Like

Didn’t know that. But your information inspired me for further checking it.

I assume that pressing CTRL+C during sudo prompt would result in 1 fail attempt record in faillock, same as typing incorrect password or empty password. To be lock for 15 minutes we need 3 incorrect attempts.

Now I’m playing around with sudo prompts after sudo gedit with different “methods” like interrupting it with CTRL+C or typing incorrect/empty password during first attempt and I made it to this issue only once after pasting empty password, next correct one was not accepted and “Sorry, try again” message appeared. After 3 attempts I did faillock --reset and it worked flawlessly.

Now I’m trying to do it again, after fresh reboot and everything works perfectly even with these “pam” messages in logs (they appear after unsuccessful password in sudo prompt, but in next attemp correct password is accepted so it is as it should be).

@Beardedgeek72
but I can log in, and i can use sudo switching to TTY.

I can do it too when error occurs. Maybe there is something wrong in GNOME?

For me it just happen only single one time from time to time (few days) and after faillock --reset problem is gone.

2 Likes

I had the same issue with KDE repeatedly in a few days now

now after that faillock --reset

my password works again.

INTERESTINGLY I could still change password in the terminal, but the POST
from anon94871076 seems to be correct, because I remember that I often
canceled a startup script I wrote as I was in hurry - so I just used CTRL-C at it.
This should be the solution for me, thanks anon94871076 :slight_smile:

I haven’t had this issue before on KDE or any of the dektops I’m running. :thinking: