Partition permissions need fixing

Wasn’t sure where to post this since I didn’t want to go to the Manjaro forums. I’m on my roommates system that still has Manjaro installed, and I just went to do a master backup for him and FreeFileSync informed me it could not create it’s lock files on 2 partitions. I’ve launched GParted and noticed that somehow Gary’s managed to switch the drives to NTFS from the Ext4 they were. What I believe happened to lock the drives is that he went into Windows. reenabled FastBoot, then went back into Manjaro without disabling FastBoot first. The issue now is he cannot get back into his Windows install to simply disable FastBoot. What I’d like to know is there anyway from within his Arch based distro to unlock those partitions so we can copy the data? Thanks

You can try ntfsfix. Like anything that modifies your disk there is some risk of data loss so be careful if you don’t have a backup.

Also, take a look at the mount command and make sure they aren’t mounted read-only. Although, if there is an issue they will be mounted read-only.

1 Like

can you explain what that does?

It repairs ntfs issues, one of which is the partition being marked dirty like it would be if fastboot was enabled.

When I used to dual-boot I used it quite a few times with good success but I would never guarantee it.

OK with that said do you think it might just be better to do the below?

Unplug Manjaro, wipe the Windows drive, reinstall Windows, and then once on it’s desktop turn off fast boot?

OK gave ntfsfix a run and no luck. He’s going to put the m.2 that Windows is on on a m.2 daughter card to see if the system will see it then. I believe it will cause I think the only reason it’s not being seen now is that his m.2 uses SATA instead of PCI-e Chanel, which means he can’t use 1 or more of his SATA ports if he wants use of the m.2.

@dalto gave the command another go with the help of addictivetips and worked like a charm for both partitions. Thanks a lot.