Partition error during installation

Previous post regarding a similar error:

Install log:

The error is something on the words of

“Installer failed to create a partition”

With a few commands, jobs, and results, or something like that. I’ll add a picture in an edit if possible.

This didn’t happen when I installed EOS in dual-boot, this time I am trying to install it by wiping Windows and I face this error.

Have you tried the same solution from that topic? Putting a new clean gpt partition table on the disk before running the installer?

Yes. I still faced the error.

Are you able to boot on the live ISO and provide the link to the following hardware output.

inxi -Faz | eos-sendlog

Here’s the output:

Here’s a picture of the error I face when I open Partition Manager:

Also, here is a copy-paste of the job, result thing I mentioned in the post:


Create a new partition table (type: gpt) on ‘/dev/sda’



Job: Create new partition table on device ‘/dev/sda’



Command: sfdisk --wipe=always /dev/sda

  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: 4060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A
    class-ID: 0104
  Device-1: md127 maj-min: 9:127 type: mdraid level: N/A status: inactive
    size: N/A

Is bitlocker disabled? I see it has raid controller and driver mode is ahci which is right.

I don’t even know what RAID is, I never used it, or set it up at all. It’s been there. Is it the problem with it? I don’t understand the bitlocker / ahci thing you mentioned, so I am asking. Is there anything I am supposed to do?

Try booting on the live ISO. Then open gparted and create a new GPT partition with gparted using device, create partition table and set to GPT. Then close gparted and run the installer and use erase disc and swap file with ext4.

Tried it, same error.

Please also refer to the imgur link I posted in this thread. It shows the error I face when I open gparted.

Take a try in the terminal
Boot the live iso
Open terminal
Look up the disk you want to edit
sudo fdisk /dev/sdx (replace sdx with your findings from lsblk)
now you must tell fdisk what to do
press g then Enter to create a new gpt table
press n then Enter to create a new partition
in the following options use the defaults by pressing enter
(In case it asks to delete a signature, do it)
last time
press w then Enter to write the above changes to disk

Now you can format the newly created partition with
sudo mkfs.ext4 /dev/sdx1 (change the x in sdx1 to your findings)

The following message is displayed:

/dev/sda1 is apparently in use by the system; will not make a filesystem here!

it looks like uefi firmware settings are reset and it has RAID mode enabled somehow… or secure boor oe CSM something in “Bios” settings…

Please show the output from

lsblk -f


loop0 squash 4.0                                                        0   100% /run/archiso/airootfs
sda   isw_ra 1.4.0                                                               
sdb   iso966 Jolie EOS_202112
│                            2021-12-17-11-32-24-00                              
│     iso966 Jolie EOS_202112
│                            2021-12-17-11-32-24-00                     0   100% /run/archiso/bootmnt
      vfat   FAT16 ARCHISO_EFI
sda   isw_ra 1.4.0

Der Doktor seems to to be right (again :wink:)
Looks like a RAID issue.
Here ends my expertise, I never setup or even dealt with RAID.

I agree it the drive is probably set in raid mode. I see it recognizes the device as md127. I would be looking in the UEFI bios under Raid and disabled or turned off.

You could take a look at this:

Especially Step 4 might be interesting (but what do I know :crazy_face:)

1 Like

Yes step 4 would be the way i would think to remove it.

It was a RAID issue.

This worked, in BIOS, changed the “SATA Mode” from “RAID” to “AHCI”.

Got too busy customizing the setup so apologies for a late reply :sweat_smile:

Here’s a picture:

Thanks everyone!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.