Partition becomes read-only when trying to delete old ~/.local/share/steam

I encountered a problem when none of my steam games would start. I reinstalled steam and renamed the old ~/.local/share/steam, so the application would create a new one, and everything was normal again. The problem right now is that I cannot remove or even move the old directory, because something in the config folder inside the ~/.local/share/steam directory doesn’t allow it to be deleted and throws my /home partition into read-only mode. This persists in live environments.
I feel like a tech-priest trying to exorcise corruption from the the spirit of my machine.

Open the folder in a terminal and run the command below. It will list all the files and folders including their owner.

ls -alF

I am the owner
Yes, I did give all permissions to all users in an attempt that it would allow me remove it
It didn’t, /home still goes in read-only mode when this folder is moved or removed. And after reboot it is still found in its place


find ~/.local/share/steam ! -user $USER

return anything?

No, sir
Neither for the new directory, nor for the old and renamed one (1111-Steam2222) that I am trying to remove

1 Like

Do you have a separate home partition? If so, what filesystem?

I wonder if this issue is due to some inconsistencies in the filesystem. If that is the case, you may want to run a filesystem check on that partition.

/home is on a separate btrfs partition. I tried reparing it in a live environment, but it errored out and didn’t do anything.

Perhaps if you post what command you ran and the terminal output, the Btrfs experts on the forum could make something out of it.

If is it irreparable, you may want to backup your personal data and configs and redo your home partition.

Will try later in the day, I didn’t expect to be doing any maintenance today. Should I do something to attract their attention to here or make a post in some other category?

No, it’s alright.

I was trying to avoid that. I read elsewhere that when a partition goes into read-only it may mean i/o problems. Could it be that …/Steam/config in particular holds some files that are used, for example, controller support and therefore are not allowed to be deleted?

You could check with the command line tool lsof and see what files are open and are being used by the system.

Here you have an article with some examples on how to use lsof:

1 Like

I tried it, checking the folder gives error 1. I think I’ll just have to reinstall the system and re-create /home because I seem to have encountered additional problems, like lutris flatpak not detecting an installed gamemode or not being able to mount /home in live environment. Shame, because it went from nobara to garuda to endeavour. Maybe it was the problem, having it go from a fedora-based system, to an arch-based one, or maybe not. Thank you for assistance!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.