Pantum M6550NW Driver for EndeavourOS

My mom recently bought a Pantum M6550NW printer but i am not able to make it work. I tried to install the 3 packages on the AUR for pantum printers (pantum_driver 1.1.5-0.1, pantum-p1000-p2000-p3000-m5100-m5200-ppd-driver, pantum-p2200-p2500-driver) but that did not work. I also went on their website and tried to install their drivers, but it seems like it’s ubuntu only (it even says it) because i get a dpkg error.

website for driver (ubuntu only): https://global.pantum.com/global/drive/m6550nw/

I am using EndeavourOS, so i can’t use that, which is why i’m asking for help.
Thank you very much,
Waaberi

Hello @waaberi
I think you need these drivers.

You can build the package from the AUR and install it using yay.

yay pantum_driver

Welcome aboard!

I did install it, but it is not doing anything.

you need to install and enable cups:

sudo pacman -S cups cups-filters cups-pdf system-config-printer --needed
sudo systemctl enable --now org.cups.cupsd.socket

then install printer with printer tool:
(system-config-printer)

1 Like

Welcome to the community :beers:

I’m sure with the knowledge around here, your printer will be working shortly.

@waaberi
Welcome to the Endeavouros forum. Thanks for giving EndeavourOS a try. I hope you enjoy your time here.

Pudge

1 Like