Pamac using wrong icon

I’m using the Sweet Plasma theme with Candy icons and Latte Dock.

Pamac just refuses to use the appropriate icon, even when I put the full path to the icon in its .desktop file.


I don’t have this issue with any other app in latte, assuming an icon exists for it. Even picking the “Software Update” in my app menu, which just opens directly to the update tab in pamac shows the correct, but different, icon.

This is the desktop file:

[Desktop Entry]
Comment=Add or remove software installed on the system
Exec=pamac-manager %U
Name=Add/Remove Software

Any advice?

copy the relevant desktop file to ~/.local/share/applications and edit this desktop file.

Sorry, forgot to mention that’s where this file already is.

Have you tried installing the icon set into the root account? You would just need to log out and back in as User:root Password:whatever you set it as. Then grab the icon package and drop it into usr/share/icons. Then reboot. Probably not necessary the last part but just in case. Then log back into your user and see if anything changed. Just be careful manipulating things logged in as root.

Also where did you get the icons from?

I have not tried that, but I’ll give it a go!

They come as part of the Sweet plasma theme.

You might also like to download the set from KDE store. There may be some missing from the theme package.


Yea, that wasn’t the exactly correct URL lol, sorry. I installed it directly through the KDE Global theme settings.

1 Like

I know. That is the full icon set I linked that comes with that theme. The theme may be missing some icons. :grinning:

Would it necessarily make a difference? The icon I want to use exists, pamac just refuses to use it.

Just giving out options to try is all. Start with the root idea.

1 Like

Fair enough! I’ll give it a go when I’m able to log out.