Pacman wants to install polkit-qt6 but it can't overwrite polkit-qt6-git


I am a noob/newb to Linux. I have been struggling to upgrade my system. When I upgrade, pacman wants to install polkit-qt6 but I already have polkit-qt6-git installed. Because of this, it seems that no matter what I do I cannot get a full system update.

sudo pacman -Syuu results in this.

Trying to resolve this error, sudo pacman -Syu --ignore polkit-qt6 > pacman_log.txt results in this.

And finally, if I try to overwrite the files in conflict with sudo pacman -U polkit-qt6 --overwrite /usr/include/polkit-qt6-1/* usr/lib/cmake/PolkitQt6-1/* /usr/lib/libpolkit-qt6* /usr/lib/pkgconfig/polkit-qt6* I get this.

How can I upgrade my system?

I would appreciate any and all help! Thank you!

What’s the output of

$ pacman -Qi polkit-qt6-git

By the way, the first link you posted is broken, so I can’t really see pacman’s error messages when you first tried to update.

This won’t work because the -U flag takes either a path to a pkg.tar.zst file or a URL that points to a package file.

My suggestion is to remove polkit-qt6-git manually first with:

$ sudo pacman -Rdd polkit-qt6-git

After that, install polkit-qt6 and mark it as a dependency

$ sudo pacman -S polkit-qt6
$ sudo pacman -D --asdeps polkit-qt6

After that, run the system update.

$ sudo pacman -Syu

The update should work fine if you haven’t broken anything in your earlier attempts.

Note: In this case, I suspect you can actually skip the installation of polkit-qt6 and go straight to the system update because the update itself will include the installation of polkit-qt6. But just to be safe, I recommend just go with the extra two steps.

Ignore this. See dalto’s answer below.

I would try:

sudo pacman -Syu polkit-qt6

That will usually resolve that type of conflict in a single command.

This is a wild guess, but is this because polkit-qt6 and polkit-qt6-git are no longer marked as conflicting packages in the latest copy of the databases (refreshed becuase of the -y flag) and the reason the OP can’t update is because the outdated database on the OP’s system still sees polkit-qt6 and polkit-qt6-git as conflicting packages?

This is the output for that command.


Looks like it. That seems broken though. polkit-qt6-git should “provide” polkit-qt6

You probably have to do it this way:

sudo pacman -Rdd polkit-qt6-git
sudo pacman -Syu polkit-qt6
1 Like

I updated pacman sudo pacman -S pacman and that worked without error and sudo pacman -Sy and that returned: [cat@large ~]$ sudo pacman -Sy :: Synchronizing package databases... endeavouros is up to date core is up to date extra is up to date multilib is up to date [cat@large ~]$

1 Like

OMG THAT WORKED TYSM!!! I very much appreciate you and @anthony93 helping me!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.