Pacman update breaks Kalu dependencies

The package is called eos-update-notifier. It is already in the repos, so you may install it like any other package. A reboot is recommended after installing it.

It is a systemd service for the current user, and to see it is running, give a command

    systemctl --user status eos-update-notifier.timer

It checks for updates soon after login. Afterwards it checks for updates after every two hours.

In addition, it also checks if there are any Arch news that may affect your machine, i.e. are related to the software you have currently installed in the machine. Note that this feature is usually able to show the relevant news, but sometimes it doesn’t. The reason is in the simple ad hoc method how the news are checked. So, to be on the safe side, it is still a good idea to check the Arch news (https://www.archlinux.org/news) with a browser at times.

DISCLAIMER: this piece of software is already tested but still quite new, so there may be issues. If you find a problem, please report it in the Bug reports area.

5 Likes

Well, I saw it is a big package… 0.02 Mb! :slight_smile:

I will test it the hard way… Switching to testing an EndeavourOS in a VM… It will hurt, or not :rofl:

For now, I got a window related to base upgrade on Archlinux. This is better than nothing :slight_smile:

1 Like

Just tried it - works great. Updated with no problems. Many thanks for the heads up on the two hour update check.

2 Likes

Is it okay to use pamac-aur-git with the new eos-update-notifier?

If you use pamac, eos update notifier isn’t necessary.

Unable to install yay as it says signature from “EndeavourOS info@endeavouros.com” is unknown trust. Managed to update everything except yay.
Edit: Now I’m getting errors with signature trying to install eos-update-notifier.

Try installing again endeavouros-keyring?!

By the way, what about removing kalu from ISO image and profiles ?

I reinstalled all keys once already just to get this far. Should i try again? I did remove kalu and pamac first.

Ouch… Maybe try resetting the keys? https://wiki.archlinux.org/index.php/Pacman/Package_signing#Resetting_all_the_keys

How do i open a folder as root with thunar in xfce so i can delete gnupg?

I have reset the keys and i still get the endeavouros signature problem and it won’t install yay.

Could you show the exact error message?

EDIT: does command (replace “key name” with e.g. EndeavourOS)

sudo pacman-key --lsign-key  "key name"

help?

1 Like

I have tried everything and it refuses to install.

[rick@endeavour-os ~]$ sudo pacman -S yay
[sudo] password for rick: 
resolving dependencies...
looking for conflicting packages...

Packages (1) yay-9.4.2-1

Total Download Size:   1.99 MiB
Total Installed Size:  6.32 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 yay-9.4.2-1-x86_64   2037.4 KiB  9.04 MiB/s 00:00 [----------------------] 100%
(1/1) checking keys in keyring                     [----------------------] 100%
(1/1) checking package integrity                   [----------------------] 100%
error: yay: signature from "EndeavourOS <info@endeavouros.com>" is unknown trust
:: File /var/cache/pacman/pkg/yay-9.4.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.
[rick@endeavour-os ~]$ 

@ricklinux
See my previous post, the EDIT.

Sorry i missed that.

[rick@endeavour-os ~]$ sudo pacman-key --lsign-key  "key name"
[sudo] password for rick: 
  -> Locally signing key key name...
==> ERROR: key name could not be locally signed.
[rick@endeavour-os ~]$ 

But replace “key name” with EndeavourOS …

Do i leave the " around the name?

Doesn’t matter.

1 Like

Thanks@manuel. I guess the keys needed updating for endevouros repo?

Yes, that’s the public key of the endeavouros repo.