Pacman layout issue


I have an odd issue where the layout of the command line text when updating with pacman doesn’t display correctly. The Y/N prompt appears in the wrong place and when retrieving packages nothing shows up.

It has worked previously, but now in Yakuake and the XFCE terminal the text is laid out like this. It doesn’t stop it working, it’s just annoying.

You might want to uncomment (i.e. remove preceding # mark(s) in the beginning of the line)


in file /etc/pacman.conf.

More info:

man pacman.conf

Unfortunately that’s even worse :joy:

1 Like

Looks like the terminal is not working correctly.
Have you tried with another terminal?

Edit: so you tried the xfce4-terminal already… Strange, as it works here as expected.

Edit2: Maybe some libs are not up to date? Try to update the system using the --noconfirm flag (only once). If the problem continues after that, then investigating the packages (e.g. AUR packages overriding official ones) might reveal the problem.

Problem solved. For some reason, and I don’t know why, or when, I modified my alias by piping pacman to tee to log the pacman output to a file in my home directory. However what I left out of the command was 2>&1.

I’ve changed the command to just run pacman and all is well again. One day I’ll know half of what I’m doing :joy:

Thanks for chipping in, it at least made my brain think differently.


There is no simple and good solution for writing to a file.
My last test (pl like paru log) :

alias pl='date >> terminal.log && stdbuf -o0 paru 2>&1 | tee -a terminal.log && date >> terminal.log'

To be honest, I can’t even remember why I wanted to do it. I’m just going to stick with the normal command.

Thanks for your input though :+1:

you do realise that pacman by default writes its log anyway? It can be found in /var/log/pacman.log

Yes, I do know that.

I can’t remember why I was doing what I was doing now. Might have just been playing to see what happened. Can’t even remember when I made the change.

Unfortunately my memory is like that. I’ll probably remember in a few months.

If you are into GUI, there is also pacmanlogviewer:

It’s a QT app so depending on your DE, it might pull in some qt dependencies.