Pacman gives error "filename to long"

I’m fairly certain that this is related, but I’m not finding anything exactly that’s helping. I have core, extra, community, multilib, and endeavouros repos, but no others. I get the following error, which does go away if I comment out the endeavouros repo in pacman.conf. I’m not sure how to fix this otherwise.The other issues I have seen have been with other repos.

error: could not open file /var/lib/pacman/sync/98ccc600-c6b1-11eb-98d5-bdc0b142bc67?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20210607%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210607T083203Z&X-Amz-Expires=300&X-Amz-Signature=dbd6b99f5220b3c6c59047e60d63a918c6aa534382c65fff7d87298cc77f7852&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=198104216&response-content-disposition=attachment%3B%20filename%3Dendeavouros.db&response-content-type=application%2Foctet-stream.sig.part: File name too long

1 Like

I think you would get better support for your issue if you open a new thread since this one is for #announcements

This is caused by a custom third-party repo in your pacman.conf, so comment that one out.

And do what pebkac suggests below:

sudo rm -fr /var/lib/pacman/sync/*
sudo pacman -Syu
1 Like

will link me to usage of github endeavors mirror still in pacman.conf?

Please post output of sudo nano /etc/pacman.conf

moved to >>/dev/null ?
:sweat_smile:

edit:
Ah, I saw that you forgot to move my post. NP, it is just hanging there like a dangling symlink in vacuum.

1 Like

That sounds like a wrong endeavouros repo address in /etc/pacman.conf or /etc/pacman.d/endeavouros-mirrorlist.

New pacman does not handle long names well.

Could you show the full contents of those files?

cat /etc/pacman.conf | eos-sendlog
cat /etc/pacman.d/endeavouros-mirrorlist | eos-sendlog
2 Likes

—deleted—

This is what I got from that:
http://ix.io/3p36
http://ix.io/3p8x

## Github
Server = https://github.com/endeavouros-team/mirrors/releases/download/mirror1/
Server = https://raw.githubusercontent.com/endeavouros-team/repo/master/$repo/$arch

you have an older installation, the Github repo entries are now fallback only usage mirrors…

put this inside:

## Germany
Server = https://mirror.alpix.eu/endeavouros/repo/$repo/$arch

## Netherlands
Server = https://mirror.easylee.nl/endeavouros/repo/$repo/$arch

## Sweden
Server = https://ftp.acc.umu.se/mirror/endeavouros/repo/$repo/$arch
Server = https://mirror.linux.pizza/endeavouros/repo/$repo/$arch

## Canada
Server = https://ca.gate.endeavouros.com/endeavouros/repo/$repo/$arch

## China
Server = https://mirrors.tuna.tsinghua.edu.cn/endeavouros/repo/$repo/$arch

## India
Server = https://mirror.ghead.work/endeavouros/repo/$repo/$arch

## Github
Server = https://raw.githubusercontent.com/endeavouros-team/repo/master/$repo/$arch

@manuel i was wondering if reinstalling endeavouros-mirrorlist will not change the list?

@ogrefriend what shows: pacman -Qs endeavouros-mirrorlist ?

@ogrefriend
Your /etc/pacman.d/endeavouros-mirrorlist is outdated, like Joe said.

Note that, in general. you need to run eos-pacdiff program after pacman updates if new .pacnew files are created. Alternatively you can click the Pacdiff & <differ> button in Welcome.

Update will not change endeavouros-mirrorlist but creates a .pacnew file. This is because user may have ranked endeavouros-mirrorlist, and we shouldn’t overwrite it.

1 Like

I ran eos-pacdiff without really thinking, which was foolish of me. My password is now being rejected. Do you know why that might be? I’m certain that I have the right one, as I just entered it.

edit: I was able to reset it with passwd, but I’m still not sure why that happened.

You must be very careful what to merge with pacdiff.

Maybe you merged /etc/passwd, /etc/shadow or /etc/group?

Pacdiff is meant for merging some useful new stuff into an existing file, or maybe removing some obsolete features in a config file. So typically only some parts of the new file should be merged to the existing file.

Some files (e.g. related to storing password info) should never be merged with it.

As a rule of thumb, if you are not sure if a file can be merged, then don’t merge. Come here and ask first! :wink:

In your case the file that needed a pacdiff treatment was
/etc/pacman.d/endeavouros-mirrorlist. Note that there might have been others too, but I don’t know which ones.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.