Pacman database files replaced with html files


A little while ago, I was going to update my packages, and I did not make any pacman or yay configuration changes since the last time I did so, but I got these errors while attempting to perform updates.

Apparently the databases somehow got replaced with the front page for a email validation service known as “ZeroBounce”, even though I have never made use of, or even known of the service until now.

I have tried removing the files, then performing an update, same result.
I have tried updating them from my endeavour flashed usb, same result.
I have tried disabling all pacman mirrors except for the first, and still the same result.

I have looked all over for anyone else having the same issue, and have found nothing regarding this issue. Any help would be greatly appreciated.

If you need any more information regarding this, like logs or similar, I can get it.

There is a recent and yet unresolved thread with similar issue:

There is a rather old but solved thread at:
https://bbs.archlinux.org/viewtopic.php?id=135310

Thank you for referring me to these threads, the second I have already come across, although did not help in my situation, and I will keep up to date on the first.

1 Like

Did you try updating your mirrorlist? Perhaps that would help.
I would remove everything inside the sync folder, update the mirrorlist and run pacman -Syyu.
If you have already tried so just ignore this post.

And welcome to EnOS’ forum!

Ionlyread pointed out that it one one of the specific mirrors that was redirecting to that website here, removing that mirror after generating a new mirror list and clearing out /var/lib/pacman/sync fixed the issue. Hope this can help someone else too.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.