Pacman and yay are in conflict

Did the git clone or makepkg command fail? Did you copy the correct AUR git URL?

I just manually installed trizen on a testing VM and it worked fine.

I didn’t know that, thank you very much. At some point I went looking for information on how to use pacman, and on some obscure site there was a lot of information, all very important, but I summed it all up in the phrase “just type -Syuu”, because my abstraction capacity is somewhat limited. I am replacing the previous summary with “just type -Syu”, thanks :+1:

1 Like

Yay still works fine. Just update, remove yay and then

$ git clone https://aur.archlinux.org/yay.git

$ cd yay

$ makepkg -si

2 Likes

Worked fine for me. ty :slight_smile:

YAY is already rebuild and can be installed again from EndeavourOS repo.

1 Like

A post was merged into an existing topic: [Archlinux]pacman 6.0 and pamac-aur compatibility

deleted by @pebcak

I have only tried sudo pacman -S trizen.

Pacman won’t find it. It is an AUR package.

2 Likes

When i type checkupdates in terminal, this is whats listed.

[dad@dad-EndeavourOS ~]$ checkupdates
akm 2.8.7-2 → 2.8.7-3
appstream-glib 0.7.18-1 → 0.7.18-2
filesystem 2021.01.19-1 → 2021.05.31-1
libnftnl 1.1.9-1 → 1.2.0-1
pacman 5.2.2-4 → 6.0.0-2
pacman-contrib 1.4.0-1 → 1.4.0-2
re2 1:20210401-1 → 1:20210601-1
yay 10.2.2-2 → 10.2.2-4

But when i do a sudo pacman -Syu i get

:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
endeavouros is up to date
:: Starting full system upgrade…
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: installing pacman (6.0.0-2) breaks dependency ‘pacman<5.3’ required by pamac-aur-git

Should I remove yay & pamac then update?

If you remove pamac, I think it will handle it from there. Once that it done, at worst you re-install yay - and eventually pamac when it is rebuilt. Because the new version of yay is already waiting for you, you should not have to do anything to be back running as normal.

I have no update info on pamac - but I am sure it will be ‘adjusted’ soon.

1 Like

Huh?

I gave the exact commands to manually build the AUR package.

:man_shrugging:

Worked like a charm, thanks! :+1:t3:

First time around i did it and yay wasn’t ready and i tried to build yay and it messed up everything. On my other two installs i was okay because they updated yay so i just remove pamac and i was good. Lesson learned … well not really. I’ll still probably do it again. :laughing:

4 Likes

In case anyone is wondering about Pamac, there is a comment from the maintainer from a few hours ago. I didn’t need to remove it (on three machines) to get the Pacman and Yay updates to work. Pamac just doesn’t open. https://gitlab.manjaro.org/applications/pamac/-/issues/1047

1 Like

hi , i have the same problem, cant install pamac-aur, i trick "target not found " with vpn. any solution until “rate limit reached”? :roll_eyes: :joy: or maybe someone with vlc installed can help me with some files? or another GUI alternatives, octopi dont work too,

The pamac code need to be modified upstreams by the developer in order to accommodating the changes in pacman. Please have a look at the link posted in the post above yours. We just need to be patient until pamac, octopi, etc. get updated.

ok thx for answer, so need help with files , last chance :joy: :see_no_evil:

What files are those you need help with?
I don’t have VLC so someone else might need to know what files?

9 posts were split to a new topic: How to install VLC