Packages newer than AUR on update

Continuing the discussion from Cannot update:

Screenshot from 2022-05-21 16-30-00

The advice is to “simply ignore it.” But the list increases.

Should we be ignoring a growing list of packages that are falling behind?

At the very least, you can remove the debug package, unless you’re reporting debug errors to Gnome Text Editor devs, it’s really not needed at all for Gnome Text Editor to function. Plus, removing it will eliminate the Missing AUR message for you as well:

sudo pacman -R gnome-text-editor-debug

As for the other packages, I’m sure others more knowledgeable will chime in soon.


They’re not falling behind, the AUR PKGBUILD files are poorly written or have another issue (e.g. the .SRCINFO is out of sync with the PKGBUILD). In the case of these packages, it’s because they are building from a VCS repository directly rather than from a set commit, tag, or release.

The solution is to report to the package maintainer so they can fix the problem.


I did as you suggested, but in my enthusiasm for bleeding edge versions, it installs the debug version by default, which I am ok with. I will just ignore that one until Gnome drops the final release, becaseu I prefer text editor to gedit.

Do you still get the message after you update the mirrors (you can use eos-welcome) and force update the repositories (pacman -Syyu) ?

I emailed the package maintainer and never received a reply. Is there some official way to report it ther than email?

You can leave a comment on the AUR page. However, if you have already emailed them, doing both seems extreme.

Those are both AUR packages. Updating the repos shouldn’t make any difference in this case.


At least other package maintainers will see it as well.

How long ago did you email them? Remember that the majority of software of Linux is maintained by volunteers, some people may only check there email once a week or less.

8 weeks ago

Would this happen to be the same thing? If so it seems it may have moved to the community repo

Are you passing the --devel flag to your AUR helper?

No. Thereason I decided to use use FF Dev Edition, is I get better load times than with regular firefox.

I just tried to remove it, so this may have something to do with the fact I switch languages from time to time depending n the which project I am working on.

Should I try removing both. Also I see there are two copies of FF Dev Ed. appearing in the list.

I don’t see how this is related to my comment.

Have you tried running yay -Sua --devel?

This thread is going off on a tangent, but I don’t understand the point of these “symlink” packages. All they do is create a symlink from one version of Firefox to another, which would seem to be completely pointless when things are being run from a desktop launcher.

Yes, this is because you have both firefox-developer-edition and firefox-developer-edition-symlink-latest installed. Both provide a version of the same desktop launcher. Which again points to the questionable usefulness of these “symlink” packages.


I agree, so I will keep it open until either the mod closes it, or you get a reasonable answer to the symlink packages, or a package maintainer fixes them so the list does not grow any more.

Maybe tht is why :enos: and other arch distros in that ilk are more suited for enthusiasts rather than the corporate world :thinking:

How do I delete both Firefox Dev Ed. and symlink package version?

Please don’t post screenshots of terminal output. Copy and paste the output here.

Also, do you have libpdfium-nojs in your ignorepkg list?

Use yay -Rc. Just be careful to review the packages it is removing.


You are trying to install developer versions and talking about corporate world :upside_down_face: