Package Updater failes to process request

When I open Package Updater, press ’ Install updates’, error message is shown: “Failed to process request”. More details: nss (/usr/lib/ conflicting files

What can I do

I suppose you haven’t seen this yet. I believe this update needs manual intervention. Try the update in terminal and post the output.


sudo pacman -Syu --overwrite /usr/lib*/
:: Starting full system upgrade…
warning: dialog: local (1:1.3_20200327-1) is newer than core (1:1.3_20200228-1)
warning: ldb: local (1:2.1.1-1) is newer than extra (1:2.0.7-2)
warning: libwbclient: local (4.12.0-3) is newer than extra (4.11.3-3)
warning: mlocate: local (0.26.git.20170220-3) is newer than core (0.26.git.20170220-2)
warning: samba: local (4.12.0-3) is newer than extra (4.11.3-3)
warning: smbclient: local (4.12.0-3) is newer than extra (4.11.3-3)
there is nothing to do

this case do it with package nss and that overwrite thing.

sudo pacman -S nss --overwrite somethingasabove

probably lib32-nss also

cannot figure out how to define that '“overwrite thing”.
Issuing sudo pacman -S nss --overwrite /usr/lib*/ gives error:

warning: nss-3.51-1 is up to date -- reinstalling
error: target not found: /usr/lib/
warning: '/usr/lib/' is a file, did you mean -U/--upgrade instead of -S/--sync?

ok there was a splitup probably :slight_smile:

if you do in terminal :stuck_out_tongue:

pkgfile /usr/lib/

you see p11-kit and lib32-nss

if you do sudo pacman -S p11-kit , it should give no issues if so you do that overwrite thing
check only first if it got issues before changing. probably a split up sometimes happend packages get splitted.

You need to remove the leading slash after --overwrite.

This looks like a mirror problem to me.

If you use a wild card, surround the whole argument to --overwrite in double quotes

zsh: no matches found: usr/lib*/

sudo pacman -S nss --overwrite “usr/lib*/” went through now with double quotes yes

open terminal :


1 ringo@BlackClover ~ % pkgfile
ringo@BlackClover ~ %

install those if error then you know which file to overwrite :slight_smile:

sorry might be wrong its symlinks just check first locations atleast first… removed those but stil the symlinks dont find the owner properly :slight_smile:

It must have had something to do with enabling testing branch in package manager earlier.
I had enabled this for going around in a bug in Samba last week.
Now I have de-activated this and all goes well.
Thanks for your input guys :slight_smile:

It would have been helpful to have said that at the beginning :blush:

1 Like

You’re absolutely right! Sorry for that :unamused:
On the other hand, this setting has been active for over a week and did not pose a problem with system updates before.