Pacdiff and Diffuse does not appear to allow me to merge more then 1 change in a file


After watching Joe’s video on using the Welcome Pacdiff & diffuse tool and I ran into a problem where:

(1) I do not see the Arrow in the GUI which would allow you to copy the changes in the pacnew file to the original configuration file:

(2) I can right click and manually merge the 1 line via the ‘Merge Selection’.

But when I try to merge any other changes either:

(a) It shows the option to merge but does not copy it to the other file.

(b) The Merge Selection is greyed out:

I also tried the"Merge from Left to Right" (CTRL M) but noticed only the first change was moved.

Is this a known bug?

The video is using meld rather than diffuse which will explain why there’s a difference.

As for how to use diffuse:man_shrugging:


Install the meld package and try again, it should default to opening pacdiff files with meld. It’s what I use to deal with pacdiffs, it works better, is easier to use, and includes those arrows to add the new code you’re talking about too!

sudo pacman -S meld

Edit: If you haven’t already, this is a great video by @joekamprad on handling pacdiffs with meld - EndeavourOS pacdiff tool - YouTube



Thanks for the suggestion guys (yeap we are all talking about the same Joe video I referenced).

So lets say I switch to using meld:

(1) Do I need to do anything to change the Welcome Pacdiff tool to use Meld instead of Diffuse?

(2) Can I remove Diffuse without breaking the Welcome tools or other Endeavor functionality?

I’m just thinking out loud here (QA hat on) about our other users who will see the problem with Diffuse not merging changes and also considering other updates which will come to the Welcome Screen Tools.

The Welcome app uses diffuse as I believe an optional dependency, but I don’t currently have any new pacdiff files to view/remove so I can’t uninstall it and test it out to be for certain at the moment. On my system I just have both installed, but it defaults to meld since both packages are very small in size it doesn’t bother me at all to have them both installed.

(1) I’m on Gnome, but when I installed meld and used the Welcome app, it automatically opened up meld for me without having to do anything extra, if that’s helpful
(2) I’d keep it installed for now, unless someone wiser than I has any thoughts :wink:

You can configure which comparison app pacdiff uses in file
/etc/eos-script-lib-yad.conf, variable EOS_WELCOME_PACDIFFERS.

As you can see in that file, by default meld is preferred over diffuse.

Simply installing meld and restarting Welcome is all you need to do.

Yes you can.


Change the Package\Configuration Utility from Diffuse to Meld.

If you decide you want to change the default EndeavourOS Compare and Merge tool (Diff) for comparing PACNEW files from Diffuse to Meld, you can do so with the following steps:

(1) Shutdown EndeavourOS Welcome tool.

(2) Install Meld and Remove Diffuse Tools:

sudo pacman -S meld
sudo pacman -R diffuse

By default the EndeavourOS Welcome Pacdiff & diffuse will use the Meld tool in place of Diffuse.

If you prefer to use a different Diff (compare and merge) tool this can be configured in the "/etc/eos-script-lib-yad.conf" file under the section labelled “EOS_WELCOME_PACDIFFERS”.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.