OS Prober no longer ran by default as of today's update of grub

If you dual boot and use GRUB, you have to follow the solution in this thread:

or you will have to use BIOS boot options to switch OS.


Thank you for the heads up

I am using KDE and today’s grub update also removed the EndeavourOS grub theme. Just a reminder that you can use the following application;

Grub Customizer

What does all this mean? I also have dual boot Windows 10 & eos-xfce on Btrfs with luks, timeshift & snaps shots. :grimacing:

1 Like

Unless you have the line


in your GRUB file Grub will no longer look for any other OS’s when it is updated.
Apparently it has something to do with the maintaner(s) of GRUB not agreeing with the maintainer of OS-Prober, in the usual LInux self-sabotaging fashion.


So we have a little bit of a tiff going on as they say? So currently though my setup has windows 10 on it. So if i were to run sudo grub-mkconfig -o /boot/grub/grub.cfg then most like my Windows 10 entry would dissappear?

There is a chance, yes.

As for the “tiff”; apparently the maintainer of GRUB considers OS-Prober unsafe? As in a security risk?
But if you dual boot you most likely have Secure Boot turned off anyway so…
(If you read the posts in the link at the top post I made there is a link to a blog post where the maintainer just consider all distros that want to support OS prober to “backport a few hundred patches”. Which is… not good).

I’ll stick to using rEFInd.


It worked exactly as i suspected. After updating no Windows 10 entry. I added the entry GRUB_DISABLE_OS_PROBER=false and regenerated grub. Windows 10 is back and also it added another entry called UEFI Firmware Settings and it boots directly to UEFI Bios.


Thanks for the heads up. Any other day, I would have noticed a GRUB update. I had over 50 updates when I ran pacman -Syu this morning, and managed to update two dual-boot machines. Not sure why GRUB updates don’t at least give “reboot recommended” message since it borks things almost every time. Glad I was able to fix things before a reboot, scream of “@#$%” and downgrade/ignore until I figured it out.

1 Like

Here is the obligatory “you’re better off with rEFInd” post… :grin:

That means the fastest fix is to install rEFInd when it won’t dual boot for you anymore. Of course, it is not for everyone - which reversing the DISABLE flag can be…


I really like rEFInd as much as i understand it. At first it was quite overwhelming but i have gotten used to the set up that i need for myself and how it works. I like it a lot on this triple boot. I could use it on my 4 TB drive a load up more distro’s but EOS has enough desktops to keep me busy! :grin:

I’ll second that… :call_me_hand:

GRUB just works automatically. rEFInd seems annoying.

Actually it’s not. I have triple boot rEFInd set up with Arch KDE, Eos-Xfce and Eos-Cinnamon. rEFIInd is a boot manager not a boot loader so when the systemt boots I have the option to load the OS from the linuz-linux image or from the grubx64.efi file depending on how you set it up. I chose to boot from the grubx64.efi. rEFInd gives me an image for each distro and i select one and it loads that particular OS. Couldn’t be easier. I remove OS prober from all installs and each has their own grub that it boots from once selected. If you choose to boot from the image then it bypasses grub and just loads from the kernel image. If I’m explaining this right? @freebird54

If you are lucky enough, I suppose - and if your distro has done the work to configure it so it (mostly) works. rEFInd only needs 2 install statements to get going, though - and neither needs the research that grub requires to get set up! Of course, yay refind and refind_install might seem annoying to some :grin:

I find it’s the constant rebuilding of grub config, and the fights between the different versions of grub on different distros (some of which don’t detect the other properly) is what it REALLY annoying. Thank heavens they both exist! LILO was a bit limited…

Yup - you explained it right. After a while it becomes the easiest way (least setup required) to boot any system - especially if there’s more than one…

I like the way i have it set up and i have no issues with it except when i do a UEFI firmware update which wipes out the rEFInd firmware entry and i have to reinstall it and change the boot order in UEFI back to rEFInd.

Thank you, I was wondering why one entry vanished from my boot menu.

well, a hearty thank-you to Beardedgeek72 (and LizziAS) for noticing this. My grub-customizer just today lost track of my other installed distros. (here I was faulting grub-customizer. Still, common advice seems to warn off folks from using grub-customizer. rEFInd seems preferred as I have read.)