OS hangs on reboot and shutdown

Hi all! I’m new to EndeavourOS and installed it on a HP Pavillion Gaming Laptop with a 8GB of RAM and 12 × AMD Ryzen 5 4600H with Radeon Graphics. I’ve tried many distros (mainly Mint and Fedora) on my laptop, but had issues installing the OS every time. Mint had problem with Radeon Integrated Graphics, which made it impossible to install. I only had success installing Fedora and had it for over 6 months.

I’m now trying EndeavourOS and loving it so far!
It has an issue too tho, it hangs indefinitely on any shutdown or reboot (from the application launcher or from terminal). I first though it could be my fault since I installed KDE Plasma and removed xfce, so I tried a second install to wipe my mistakes and start anew. No luck, still the same problem with the default xfce… The CapsLock LED also flashes every 500ms (2x/sec) when it hangs.

I’m not sure which logs would be relevant to help with the issue, but feel free to ask for any of them, I’ll provide on ask.

What is the last thing you see displayed when it is failing to shutdown?

Something like this:

note: Xorg[680] exited with irqs disabled
Fixing recursive fault but reboot is needed!
BUG: scheduling while atomic: Xorg/680/0x000000000
Modules linked in: [*Enormous list of modules*]
BUG: kernel NULL pointer dereference, address: 0000000000000000
#PF: supervisor read access in kernel mode

After what, nothing happens (I’ve tried letting it run for over 5 minutes).

Edit: The lines shown when hanging seems to change frequently, here is a picture of the type of messages that seems more relevant.

when running from terminal what shutdown command are you using? systmctl shutdown or shutdown

sudo shutdown now or sudo reboot now. What is the difference between systemctl poweroff and the regular shutdown? I though the regular shutdown was a symlink to systemctl poweroff?

I’ve also tried systemctl poweroff and got the exact same problem.

It looks like maybe something is crashing during your shutdown.

Can we see the output from inxi -Fxxxz

It should be use systemctl either way so it won’t matter.

Sure, here it is:

  Kernel: 6.2.7-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    Desktop: KDE Plasma v: 5.27.3 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 7
    dm: LightDM v: 1.32.0 Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec1xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 87B0 v: 31.23 serial: <superuser required> UEFI: AMI
    v: F.25 date: 08/18/2021
  ID-1: BAT0 charge: 30.3 Wh (67.8%) condition: 44.7/44.7 Wh (100.0%)
    volts: 11.4 min: 11.6 model: Hewlett-Packard Primary type: Li-ion
    serial: N/A status: discharging cycles: 402
  Info: 6-core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64
    type: MT MCP smt: enabled arch: Zen 2 rev: 1 cache: L1: 384 KiB L2: 3 MiB
    L3: 8 MiB
  Speed (MHz): avg: 1568 high: 2420 min/max: 1400/3000 boost: enabled cores:
    1: 1383 2: 1400 3: 2413 4: 2420 5: 1400 6: 1400 7: 1400 8: 1400 9: 1400
    10: 1400 11: 1400 12: 1400 bogomips: 71894
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA GP107M [GeForce GTX 1050 3 GB Max-Q]
    vendor: Hewlett-Packard driver: nouveau v: kernel arch: Pascal pcie:
    speed: Unknown lanes: 63 ports: active: none empty: HDMI-A-1
    bus-ID: 01:00.0 chip-ID: 10de:1c91 class-ID: 0300
  Device-2: AMD Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel
    arch: GCN-5 pcie: speed: 8 GT/s lanes: 16 ports: active: eDP-1 empty: none
    bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300 temp: 35.0 C
  Device-3: IMC Networks HP TrueVision HD Camera type: USB driver: uvcvideo
    bus-ID: 1-3:2 chip-ID: 13d3:56c9 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.7 compositor: kwin_x11 driver: X:
    loaded: amdgpu,modesetting alternate: fbdev,nouveau,nv,vesa
    dri: radeonsi,nouveau gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: ChiMei InnoLux 0x150d res: 1920x1080
    hz: 60 dpi: 142 size: 344x193mm (13.54x7.6") diag: 394mm (15.5") modes:
    max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.49 6.2.7-arch1-1) direct-render: Yes
  Device-1: NVIDIA GP107GL High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: speed: Unknown lanes: 63
    bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
    driver: N/A pcie: speed: 8 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound API: ALSA v: k6.2.7-arch1-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.67 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie:
    speed: 5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 2-4:2
    chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 704.24 GiB used: 34.96 GiB (5.0%)
  ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG40ZNV256G KIOXIA
    size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: HP00AE00 temp: 43.9 C scheme: GPT
  ID-2: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-1: / size: 447.75 GiB used: 34.86 GiB (7.8%) fs: ext4 dev: /dev/sda2
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda3
  System Temperatures: cpu: 37.8 C mobo: N/A
  Fan Speeds (RPM): fan-1: 0 fan-2: 0
  GPU: device: amdgpu temp: 36.0 C device: nouveau temp: N/A
  Processes: 322 Uptime: 2m wakeups: 1 Memory: 7.13 GiB used: 3.18 GiB (44.6%)
  Init: systemd v: 253 default: graphical Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1383 Shell: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.25

I would try installing the proprietary nvidia drivers and see if that helps.


That did the trick! I’ve run sudo pacman -S nvidia and sudo pacman -S nvidia-libgl, I’ve updated the system (sudo pacman -Syu) and rebooted. It now reboots or shutdowns quickly and stably.

Thanks! :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.