Oracle database xe


I am new to linux(just changed from windows 10 week ago). I am a student currently learning oracle sql. I want to install oracle sql on my endeavourOS.

I read arch wiki for installation of oracle-xe but in the comments saying not working.

I tried instaling oracle 19c through runinstaller and it is showing this error

error while loading shared libraries: cannot open shared object file: No such file or directory

I want to install 19c or express edition if possible.

Can any one help me through the process?

How did you try to install it? Did you try to install oracle-xe (Oracle Express Edition) from AUR ? Which instruction on the Wiki did you follow?
Difficult to help without information.

1 Like

How can we fix something that is broken?

If you need this then run it on a supported platform, ideally one that is supported by the place in which you are a

so they can help you when things break or don’t work.

Alternatively, a quick search for

would have found several threads on the forum, including a solution here:

1 Like

This worked but it is showing OS is not supported.

Screenshot from 2022-02-20 11-26-41

Should i continue with installation?

So I cannot run oracle-xe on endeavour?

I wouldn’t continue, because prerequisites will not be checked.
Where and which installer did you download (Link ?)? I could only find rpm packages for Linux. Maybe I missed something.

Nevertheless, I would try to install Oracle Express Edition from AUR.
yay -S oracle-xe should do the job. It’s version oracle-xe Installation worked here, but I didn’t test it.

1 Like

This is entirely up to you. It is your system and your responsibility.

Who knows unless you try? Or, refer to what you read before:

which implies it doesn’t work on any Arch-based distro.