Optimus manager, i3 and nvidia mode, tray icons not showing

I have an odd issue.

I installed optimus manager and made sure it always uses the nvidia card.

It all seems like it works fine. I switch from integrated graphics to nvidia and I get logged out and then log in.

Now my tray icons do not show anymore. The apps are running, if I try to start Dropbox then it says something like “app already running on (pid-number)”.

I’ve no idea what happened.


EDIT: Do I even need optimus manager? I have no idea really to be honest. It does not seem like I get better fps or so in games. Was my nvidia card already used and this does basically nothing?

per default it will boot on igpu if you install nvidia drivers and add modesetting option on boot…
To switch you need to add a switcher or switch manually… or indeed set it to boot with nvidia gpu enabled per default.

if switching drivers from nouveau to nvidia it will change the display names… so you may need to edit configuration… on the bar part…

    tray_output HDMI-0
    tray_output primary


I see. So I was most likely using the igpu before this then.

What is the best way of doing this? Seems like booting with nvidia gpu is the better choice since I want to use that, basically always… That would also make me not have to do the switch when I boot as that makes the boot time longer (yes, just a few seconds but still - bloat :joy: ).

I looked into this and for sure, the screen is not primary anymore. Setting it to primary made one of the icons show up again. Not the dropbox one though. :thinking:

I used xrandr --output eDP-1-1 --primary but I doubt that is permanent… Right? Would I need to set that in my config-file?

But maybe not if I run with kernel option so it’s nvidia at boot?

Damn, I feel like Jon Snow here (“you know nothing Jon Snow”)

thats not permanent indeed, but you can use arandr and save the xrandr script as monitor what will get applied each login:

use nvidia gpu only:

I kinda had a feeling it had something to do with arandr or xrandr. I’m learning!

Yes, I found this after I posted. Will look into it for sure!

Thanks a lot for your patience with my questions.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.