Opening terminal apps from dmenu


When opening apps that require terminal directly from application searcher (the default one in the i3 EOS desktop) these open without correct interface. This happens in i3 for zellij and nvim.


You have two choices (that I know of):

Option One: Type the name of your terminal followed by “-e” and then the name of the CLI app.
→ This is actually slower than launching your terminal then typing maybe two letters for the CLI app, so this isn’t really efficient.


xfce4-terminal -e ranger

Option Two: Use rofi instead of dmenu for terminal apps. Rofi will launch CLI apps in your default terminal as desired.


Thanks for your help. I was looking at the config and I am unsure of whether rofi or dmenu is used. But i can tell you that the app does launch but the interface is completely different.

From terminal:

From dmenu or rofi:


You’re welcome. Please mark this thread as solved so that others can easily find it.

1 Like

Yes, I’ve read some pieces of advice of Der Doktor and others and I failed. My workaround:

sudo ln -s /usr/bin/xfce4-terminal /usr/local/bin/uxterm

Genuine question: Why would you symlink to another terminal that may have different/limited features?

No i still haven’t solved it in the screenshots above it shows both versions.

Seems I misinterpreted your response. Sorry.

From the terminal, what command do you type?

And what do you type in dmenu and rofi?

From the terminal i just wrote zellij in rofi I searched zellij as well.

Because it works. As long OP knows what this line does.
I’m not proud of this workaround and all-ears to hear a better solution though.
Edit 2: I tested rofi with this line in config
bindsym $mod+x exec --no-startup-id rofi -show drun -run-command "i3-msg exec '{cmd}'" -show-icons

I see.

Based on the context of this thread, I’d say the better option is to use a more modern terminal, like suggested by the zellij devs.

Should i then change the default terminal to alacritty?

It may work, try it.

I’m not sure why the app looks different if you use practically the same command to launch it. This doesn’t happen on my end with any of my CLI apps. Ranger, Btop, etc. all look the same whether launched from a terminal or from Rofi.

Where is this changed? In .profile?

From dmenu or rofi, look for xfce4-settings-manager. Then look for “Default Applications”.

Question: What do you use zellij for?

I think this may be the issue xterm is being used as the default but I can find where to change it.

Do you see this? You can get to this by typing xfce4-settings-manager in a terminal.


I think this maybe the answer:

Nope …

No luck changed the .profile TERMINAL variable but no luck. I did restart.