OpenGL Renderer stuck in KDE taskbar

image

Appears when running several different games through wine-ge, mostly seperate from steam. Only is an issue on wayland.

Relevant posts I found with an identical issue:
https://www.reddit.com/r/linux_gaming/comments/15xd1wo/opengl_renderer_appears_o_the_taskbar_and_cannot/
https://www.reddit.com/r/kde/comments/14zt8mr/is_there_a_way_to_get_rid_of_the_opengl_renderer/

I’m wondering if it is an issue with that widget, if you change it to icons only does it do the same?

image
doesn’t seem to be any major differences

Yer it was just a guess, have you checked with any program like htop etc to see if it is still actually running?

I’ve looked through a lot of the processes running with ps ax, and even tried killing each process with “wine” in their name.

also looked through processes named with “renderer”, “opengl”, etc. Including the names of the games that caused these task manager entries.

Essentially, I haven’t found anything running related to it.

It’s beyond me then. Someone with some more knowlege will probably help you out soonish. In the mean time have you checked out KDEs forum and bug tracker to see if anything there could help you?

I’ve looked through there and a lot of other forums, haven’t found anything thus far. Likely there’s something relatively surface level that I’m missing, since this exists on all my installation for months and is too obvious of an issue to be missed so entirely.

Those two Reddit links are still the only ones that I’ve seen mentioning this issue thus far

Hi. I’ve registered just to help you and others who struggling to find solution online.
I’m using Fedora 39 and had same issue.
But I tried run games through Steam and this window did not appear.
Next what I did - switched runner in Lutris to “Proton Experimental” (this one is shipped with Steam).
And done this annoying window also doesn’t appear any more.
Issue solved.

1 Like

I haven’t been able to make all my games run through proton, since running non-steam games through proton is not supported. It’s an imperfect solution at best, since the problem itself wasn’t found. Thanks for the lead though, I will keep trying.