OpenGL 3.3 drivers?

I’ve installed the kitty terminal on my 10 year old acer laptop (on which endeavourOS generally runs beautifully), and when I try to run it I get this error:

[311 14:30:43.105868] [glfw error 65543]: GLX: Failed to create context: GLXBadFBConfig
[311 14:30:43.105937] Failed to create GLFW temp window! This usually happens because of old/broken OpenGL drivers. kitty requires working OpenGL 3.3 drivers.

Any tips on if/how it’ll be possible to resolve this? inxi -G gives me the following:

Graphics:  Device-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel 
           Device-2: ALi type: USB driver: uvcvideo 
           Display: server: X.Org 1.20.9 driver: intel unloaded: fbdev,modesetting,vesa resolution: 1600x900~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing.

Just guessing because I’m not using kitty, but maybe package glfw-x11 needs to be installed? Or maybe it is an outdated version?

First I’d do sudo pacman -Syyu

Thanks, I tried it but I still get the same result. I suspect this is a deeper issue relating to the very old machine/graphics card. I just installed it on my only 5-yr old manjaro desktop and it runs without any problem.

I just installed kitty and it runs OK without any error messages.



:sweat_smile: and you run kitty directly with startx, without a Desktop Environment on what it is running?
It could be that compositor of the DE is running on another version of openGL as KDE is doing per default…

Ah! On the machine that’s giving me trouble I’m running openbox with picom. On my other machine, where kitty seems to work fine, I’m running i3 + picom.

picom seems not involved in that… but then it can be only GPU and driver:
what shows:

glxinfo -B