Open terminal context menu in dolphin filemanager not working

The “Open Terminal” context menu in dolphin file manager is not working and my default terminal is konsole.

System:    Kernel: 5.13.10-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=6b827258-6457-4cf2-97f4-5adbef9e8bf8 rw quiet loglevel=3 
           Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: EndeavourOS base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 15-3567 v: N/A serial: <filter> Chassis: type: 9 serial: <filter> 
           Mobo: Dell model: 0D53F5 v: A00 serial: <filter> UEFI: Dell v: 2.14.0 date: 01/13/2021 
Battery:   ID-1: BAT0 charge: 40.0 Wh (100.0%) condition: 40.0/41.4 Wh (96.4%) volts: 16.1 min: 14.8 
           model: LGC-LGC2.80 DELL 7PY0D0A type: Li-ion serial: <filter> status: Full 
CPU:       Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake note: check family: 6 
           model-id: 8E (142) stepping: 9 microcode: EA cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21607 
           Speed: 712 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 712 2: 741 3: 800 4: 747 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:5916 
           class-ID: 0300 
           Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] vendor: Dell driver: radeon 
           v: kernel alternate: amdgpu bus-ID: 01:00.0 chip-ID: 1002:6660 class-ID: 0380 
           Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:3 chip-ID: 0bda:5769 class-ID: 0e02 
           serial: <filter> 
           Display: x11 server: 1.20.13 compositor: kwin_x11 driver: loaded: intel,modesetting unloaded: fbdev,vesa 
           alternate: ati resolution: <missing: xdpyinfo> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel alternate: snd_soc_skl 
           bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403 
           Sound Server-1: ALSA v: k5.13.10-arch1-1 running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: e000 bus-ID: 02:00.0 chip-ID: 8086:3165 
           class-ID: 0280 
           IF: wlan0 state: up mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel port: d000 
           bus-ID: 03:00.0 chip-ID: 10ec:8136 class-ID: 0200 
           IF: enp3s0 state: down mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-8:5 chip-ID: 8087:0a2a 
           class-ID: e001 
           Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled rfk-block: hardware: no software: no 
           address: see --recommends 
Drives:    Local Storage: total: 931.51 GiB used: 131.6 GiB (14.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB block-size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: SDM3 scheme: GPT 
Partition: ID-1: / raw-size: 100.01 GiB size: 97.88 GiB (97.87%) used: 6.99 GiB (7.1%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 
           ID-2: /boot/efi raw-size: 200 MiB size: 196.9 MiB (98.44%) used: 282 KiB (0.1%) fs: vfat dev: /dev/sda2 
           maj-min: 8:2 
           ID-3: /home raw-size: 831.3 GiB size: 817.18 GiB (98.30%) used: 124.61 GiB (15.2%) fs: ext4 dev: /dev/sda3 
           maj-min: 8:3 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 50.0 C mobo: 48.0 C gpu: radeon temp: 46.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 184 Uptime: 17m wakeups: 1 Memory: 7.64 GiB used: 2.11 GiB (27.7%) Init: systemd v: 249 tool: systemctl 
           Compilers: gcc: 11.1.0 Packages: pacman: 961 lib: 219 flatpak: 0 Shell: Bash v: 5.1.8 running-in: konsole 
           inxi: 3.3.05 

First, is your system updated and have you rebooted your system since the recent plasma updates.

If so, try running dolphin from a terminal and see if any errors show up in the terminal when you try to use “open terminal”

I just installed endeavour os (only a 3 hours ago). i have updated my system and rebooted the system. when i click on open terminal option in dolphin nothing happens.

I just noticed it’s not working on my plasma install also. In the terminal it say’s

[ricklinux@archsnap ~]$ open terminal
bash: open: command not found
[ricklinux@archsnap ~]$ 

no the right click menu option called “Open Terminal” in Dolphin File manager, is the one not working.

  • Open konsole normally
  • Type dolphin
  • From dolphin try to use “open terminal”
  • See if there is an error in the konsole you used to open dolphin

Maybe i misunderstood what you meant? Open dolphin from the terminal first and then try open terminal with right click?

[ricklinux@archsnap ~]$ dolphin
kf.coreaddons: no metadata found in "/usr/lib/qt/plugins/kf5/kio/" "Failed to extract plugin meta data from '/usr/lib/qt/plugins/kf5/kio/'"
kf.coreaddons: no metadata found in "/usr/lib/qt/plugins/kf5/kio/" "Failed to extract plugin meta data from '/usr/lib/qt/plugins/kf5/kio/'"
kf.coreaddons: no metadata found in "/usr/lib/qt/plugins/kf5/kio/" "Failed to extract plugin meta data from '/usr/lib/qt/plugins/kf5/kio/'"
kf.coreaddons: no metadata found in "/usr/lib/qt/plugins/kf5/kio/" "Failed to extract plugin meta data from '/usr/lib/qt/plugins/kf5/kio/'"
kf.dbusaddons: Can not find 'kdeinit5' executable at  "/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl" "/usr/bin, /usr/bin"
kf.dbusaddons: Can not find 'kdeinit5' executable at  "/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl" "/usr/bin, /usr/bin"
WARNING: Please setup an KMessageHandler with KMessage::setMessageHandler to display message propertly.
(Could not launch Terminal Client)ERROR: Could not launch the terminal client:

KLauncher could not be reached via D-Bus. Error when calling kdeinit_exec_with_workdir:
The name org.kde.klauncher5 was not provided by any .service files

Try installing the package kinit

1 Like

That works for me! :smiling_face_with_three_hearts:

1 Like

Why would that be missing?

It is more than likely a packaging problem.

Well for me I’m on an Arch install so i can see that.

Welcome to EndeavourOS

Did that work for you also?

That does’nt worked

Maybe yours has a different error message then as mine is an Arch install i did myself so i could have been missing that package. Maybe you try the same open dolphin in the terminal first and then right click in dolphin and post the terminal output with code tags for @dalto

Please follow these steps and report back the output.

after installing kinit, I restarted the system and it worked.

Thank you guys!!

Endeavour forum is so awsome.

Then you should mark @dalto’s post as the solution, as he is the one who solved this problem for you!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.