Open file dialog: how to show hidden files

I want to see hidden files by default in the open dialog, especially in text/code editors. I can right click and select hidden files, but I want this to be the default.

I have tried the following:

gsettings set org.gtk.Settings.FileChooser show-hidden true
gsettings set org.gtk.gtk4.Settings.FileChooser show-hidden true

I have changed this setting in:
~/config/gtk-2.0/gtkfilechooser.ini

None of these changes take effect in code/text editors, gnumeric, etc.

I feel certain the file chooser is the right place as other settings have taken effect, such as startup-mode.

What am I missing? How can I change the hidden files behavior?

I’m using i3 for wm.

Thanks!

Generally, CTRL+H will do the job.

5 Likes

That’s too easy. :wink:

1 Like

You learn something new everyday on this forum :enos_flag:

1 Like

I already knew but had forgotten about it. This just reminded me. I forget things easily if I’m not using them.

You’ve probably forgotten more about linux than I know linux :rofl:

No… i doubt that! I know somethings but I don’t know that much. I just try to use the knowledge i do have and it helps me to figure certain things out. I’m not one to write things down so it always makes me have to think but sometimes that’s not helpful. :grin:

This is related to the Gnome DE, but it may or may not carry over to others. When using Gnome’s Nautilus file manager, if I had files hidden here, then any open dialog box will not show any hidden files. But if I show hidden files in Nautilus, then any open dialog box will show any hidden files. At least in Gnomes case, this setting appears to be somewhat tied to the file manager as the de facto setting, so perhaps depending on your file manager of choice for i3, it may be something similar, but perhaps it may not be of course too.

On KDE it works in dolphin.

1 Like

EOS i3 has Thunar installed, which I like. I have hidden files set to be shown, and that works fine for displaying in Thunar only. But has no effect elsewhere.

The gsettings I changed are “supposed” to be the solution. But they do nothing.

Since there is supposed to be a way to change the default, I would like to know what it is or why this doesn’t work. Right-clicking or ctrl-h is a tedious work around at best.

Where is elsewhere?

Many apps that use gtk filechooser. Ones I tested:

Visual Studio Code
vscodium
Geany
Gnumeric

It does work in gimp and xed, however.

It is most annoying in code editors. I’m not a vim/emacs person, and I use vs code daily.

None of the settings here have any effect, so this is likely a GTK4 bug (or they’ve moved the settings elsewhere, or have decided to ignore them entirely).

Is it just my imagination, or do a lot off apps using gtk have “irregular” behavior. Meaning that what one reads in gtk documentation, stackoverflow, Arch wiki, etc., report how things are “supposed to be” but in reality are too often “off”?

I thought when I learned about gsettings that I had found Shangri-La! But alas, I found Paris. It looks good, but many things work in a difficult to understand fashion. C’est la vie!

Thanks for the input.

2 Likes