Only two keys are swapped in keyboard layout?

Hi, I am new to EndeavourOS, I just installed it yesterday.

I am having weird issue with my Macbook Air’s keyboard. Everything is working correctly except these two keys:

Screenshot from 2022-02-12 18-18-37

When I press one, it gives me the other, and vice versa. While installing, I selected Macbook Air from the list and Turkish Q from the next list. So I think I did it correctly.

I tried different layouts too: Turkish Alt-Q and etc, but this problem isn’t solved. How can I solve this issue?

Still having this issue.

I may not be a big help since I don’t run Mac anymore. If not already checked there is something in the arch wiki.

Thank you.

I followed the 7th section which is " < and > have changed place with ^ and ° (or @ and #, or ` and ~)"

Sadly, nothing changed.

Similar problem, a Mac as well:

can’t speak for the Turkish layout, but on my Macbook Air, the keyboard layout also differs from the standard… mine comes with a ‘Dutch’ qwerty layout, but in reality, it’s more like a regular US layout, with an ISO Enter key, small Shift button, and relocated backspace and tilde keys…

What OG Qwerty NL should look like:

What US qwerty looks like:

what Apple thinks NL Qwerty is:

could be that apple did something similar on your keyboard, and jumbled some stuff around?

If you can’t find the right keyboard layout you could probably use xev and xmodmap to remap those two keys